Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
I just bought an 05 300c and the nav screen is just black and grey with lines across it. I got to checking and there is no disc in it. Is this all that's wrong? Will the nav work when I put a disc in it? Can I just go to a dealer and buy a disc? And one more question, which is the best disc to get? thanks Dan
 

·
Registered
Joined
·
96 Posts
Discussion Starter #2
I sent the wife in to grab a disc from the dealer and it didn't do anything. Never mind the cost of the disc.............$270.oo bucks! OMG!
 

·
Registered
Joined
·
57 Posts
Going on experience with other electronics screens, when you see something like that it usually means that connectors are bad somewhere, or that one of the ribbon cables is broken. Either way, not easy to repair - probably better off replacing it with an aftermarket unit (has to be cheaper than what Chrysler charges!)
 

·
Registered
Joined
·
979 Posts
yeah if it didnt have a disc it would have had the insert screen disc. Like mentioned by yar it could have somehow got unplugged hopefully behind the radio or the tape could have gotten unplugged from the screen. Or what could be the worst when the previous owner was updating their nav disc they turned off or started the car before the installation was complete, which could have fried the unit or really messed it up. If your gunhoe about fixing it call tvandnav2go maybe dom has a solution or could reccomend something.
 
1 - 5 of 5 Posts
Top