Chrysler 300C & SRT8 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1 (Edited)
Could someone do me a huge favor please? My car (2014 300C 5.7L) threw the serpentine belt today and destroyed the tensioner on the highway. Had to get towed :(
Would someone take a picture of the upper idler pulley and/or let me know if the pulley covers the whole belt? My pulley only covers 3/4 of the belt, and 1/4 of the belt doesn't even ride on the pulley. The dealer said its normal, but i don't think it is. It's putting a groove in the belt already in one day...

Not getting off to a good start with this car :(
Thanks if anyone could help!

 

·
Premium Member
Joined
·
150 Posts
I'd say an incorrect pulley assembly was installed that is further away from the engine. The belt should ride dead centre.

Perhaps they installed an idler pulley assembly from a RAM or other 5.7 model.
I know my RAM 5.7 and 300C 5.7 accessory drives are unique to each other.
I remember trying an idler pulley swap in the past and they were not compatible.

Bruce
 

·
Registered
Joined
·
89 Posts
Discussion Starter #3
The circled idler pulley is the one that was on there. I think it's damaged/back edge of it is ground off. The tensioner melted off too from the belt, and the belt was all caught around this one and the other pulleys.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #4
Thanks for the help Hosehead.

Yah, its destroyed. It's missing like 1/4" of the side of it. I tried telling the dealer this and had to go over to another dealer to get a pulley so they would believe me!! When they finally pulled it off they saw the stuff melted into the backside of it! Been a PITA day, not impressed with this dealer...
 
1 - 4 of 4 Posts
Top