Chrysler 300C & SRT8 Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
2,578 Posts
Discussion Starter #1
ok so its definitely not my first time installing HIDs.. but i ordered a set from ebay and got the anti flicker harness.. installed it, flipped the switch, and smoke came out of the capacitors

i had ordered from HIDgate.. can someone take a pic or show me where the wires go? i may have plugged it in the wrong way
 

·
Registered
Joined
·
2,578 Posts
Discussion Starter #3
here is how i connected them:





there is no way to "reverse" them.. everything only plugs in 1 way.. i plugged that blue part in, then connected the factory wire to the end of it.. unless the factory wire is supposed to attach to the ballast, then thats where i went wrong
 

·
Registered
Joined
·
158 Posts
the plug that goes into the ballast dont try to put the clips over that big stubb pointing towards the middle there...thats the wrong way

you can however reverse the wires going into the factory harness on the other end
 

·
Registered
Joined
·
2,578 Posts
Discussion Starter #5
i did NOT put it over the big stubb.. sorry the pic came out like that.. it went over the tiny stub on the other side, which looks like it made sense

the wire going to the factory harness cannot be reversed...
 

·
Registered
Joined
·
2,578 Posts
Discussion Starter #8
actually, my factory one doesnt look like that. rather the HID kit one looks like that. still.. its a 1 way groove
 

·
Registered
Joined
·
158 Posts
so you're saying you cant make the clips go on the opposite side of the ballast harness due to the groove in the factory harness or the ballast harness?
 

·
Registered
Joined
·
2,578 Posts
Discussion Starter #12
i just had a pro check it out.. everything is wired correctly.. i had 2 kits, tried both of them, everything is DOA... gotta email and get a new set
 

·
Registered
Joined
·
979 Posts
this is weird you could flip the capacitor 180 degrees and plug it where it needs to be. It definetely sounds like the cap was reversed and the neg went into the positive, positive into negative that is the only way to blow the caps unless the caps where to small. like if you reversed the clips to make the hids work to start you would have to flip the capacitor as well. if you smoked the caps you can still try to use the hids just to check they still work they will prob flicker. if your hids dont come on you def need to flip the plug from the ballast to the stock harness 180 degrees and then the hids should come on or at least one without the caps.
 

·
Registered
Joined
·
2,578 Posts
Discussion Starter #14
ok update: i tried all sorts of configurations, flips and flops.. and all the capacitors blew. so i threw them away, used regular harnesses, and they work nicely, no flicker :) no capacitor needed. the only diff is that i used a high guage wire (ie: thicker wire) so i guess electricity flows better through that
 

·
Registered
Joined
·
146 Posts
i just ordered an hid kit from hidgate also. is there a right way to install this? should i use a test light? im kinda getting worried that i would blow my up the ballast or something. im getting confused on the right way to install this. someone please help
 

·
Registered
Joined
·
146 Posts
I just got my hid kit from hidgate and when i installed it, the lights did not turn on. so then i reversed the plug from the factory plug into the harness and it turned on for 5 seconds then turned off. so then i turned off the light switch and turned it back on and it turned on for like 5 seconds and went off again. what am i doing wrong? im getting frustrated
 

·
Registered
Joined
·
979 Posts
did you install your antiflicker capacitors or specify to hidgate that you needed these? that seems to be your problem our cars flicker with aftermarket hids, thats why most people go with hidgate because they provide them free of charge.
 
1 - 20 of 25 Posts
Top