Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
So i received my brand new 22' velocity rims and tires today, they shipped pre- mounted and balanced with about 42psi. (which i already hit a local tire shop and they brought down my psi to 30)

I mounted them to my custom 2006 Chrysler 300 limited edition (((LOVE THIS CAR BY THE WAY))) only 98K mint condition inside and out. Ive had it for 6 months no issues. Had the stock chrome rims, but wanted to upgrade when i seen these style rims.

My problem is, when i hit about 40mph i start to get a steering wheel shake... ughh

1. even thought they are balanced maybe i need a better balance?

2. on a previous thread, someone said something about their being a RETAIN CLIP and to remove it, but i cant seem to find a picture of it online so i know what im looking for?



any help for the 2017, would be awesome thats so much.
 

Attachments

·
Premium Member
Joined
·
1,788 Posts
On a 2006 with 98000 miles I bet your bushings are all done. Tie rods... you name it... the whole set up, probably. That's where I am on my '07. Time to start switching out parts. :)
 

·
Currently Away From 300C Forum
Joined
·
19,574 Posts
Your other issue may be that the wheels are lug centric vs. hub centric. The LX platform doesn't seem to tolerate lug centric wheels very wheel. I had to tear off the lug centric wheels that came on my CV 300C because it was so bad.

You can try some hub centric spacers behind these wheels (3mm to 10mm thickness) and they may help.

Good luck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4 (Edited)
The car had no issues at all with the stock chrome rims though, so leaves me to believe its just needs balanced again or something else, going to get it looked at today.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
UPDATE: I actually noticed on another post about these little factory clips on the lug nuts, i removed them 2 on each wheel, put back on rim/tire/ tighten the lug nuts and the vibrations have gone away. crazy huh.

thanks
 

·
Currently Away From 300C Forum
Joined
·
19,574 Posts
Not crazy. Now the wheel is sitting flush on the rotor hat which is what you want. I even had to take those darn things off my Ram truck!
 
1 - 8 of 8 Posts
Top