Chrysler 300C & SRT8 Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys, I have a 2012 Chrysler 300S. The headlight went out and after replacing it, it still doesn't work. Now, to be honest, I slacked long enough replacing it that they both went out. I went to the store and bought two headlight bulbs and the drivers side worked after replacement. So I swapped them out to make sure the bulb wasn't bad and the one known to be good didn't work on the passenger side. I fiddled the wires and everything looks ok... even though it's hard to get a good look.

I am under the impression the ballast is built into the bulb but I'm not positive. It's a bulb with a 1 inch square at the base.

The car uses the 100 HID bulbs and the lights also turn as I turn the vehicle... I can't remember what that's called.

Any ideas what's wrong?
 

·
Registered
2006 CRD Touring
Joined
·
2,749 Posts
Something odd here, as HID bulbs are designed to last for more than 3 years. I've just replaced mine after 8 years. The square box at the base is not the ballast, which is located under the headlamp unit. Also, you need to be sure that replacement bulbs are of OEM quality.
 

·
Administrator
Joined
·
13,065 Posts
the main ballast is affixed to the base of the headlight capsule. I suspect the main ballast has failed since you tested that side with a known, good bulb.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Well that's a bummer... that ballast looks like a pain to replace. I suppose that's pretty expensive to have replace at the dealer right?
 
1 - 10 of 10 Posts
Top