Chrysler 300C & SRT8 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
597 Posts
Discussion Starter #1 (Edited)
Hey guys,

So I've been actively reading this forum for a little bit now as I've been planning on pickin up a 300 (join date says april but i've been reading the forum for quite a while before i got an account).

Well I finally did last night. I got myself a 2007 Brilliant Black Chrysler 300 Limited. Its got 12,000 KM on it ( sry dunno how many miles that is, im canadian :D ) and was previously owned by an executive at Chrysler.

Its got just about every feature he could stuff into a limited except a uConnect system. I may or may not try n buy one and get it installed. Haven't decided yet.

I'm super pumped to get this baby home. I pick it up in a 2 hours!!! WOOHOO

Cheers,
Bryan
 

·
Premium Member
Joined
·
10,829 Posts
Congratulations on your great purchase. We've had a few other members purchase LX vehicles previously owned by Chrysler executives.

Good luck with everything you are hoping this car to be. It sounds like you won't need to be adding too many mods, either. You mileage is approximately 7,500.

Welcome to the forums!
bruno
 

·
Registered
Joined
·
683 Posts
welcome and congrats on choosing the right color. It may take a little extra work to keep it clean but when it is there is nothing classier looking
 

·
Premium Member
Joined
·
2,241 Posts
Hi and welcome to the forum from Scotland. You sound just like every other new 300C driver - bet you have a huge ear to ear grin to go with the WOOHOO!! The grin, the excitement, the shear pleasure - that is what it is all about. Enjoy your new car.
Cheers John
 

·
Registered
Joined
·
1,369 Posts
Welcome to the forum,I have a 05 limited BB also and still loving it.I see you been reading the fourm for a while so I guess you know that all your questions about mods would be anwserd here.Good luck with your new ride.
 

·
Registered
Joined
·
435 Posts
Kewl, congrats and yea for you... welcome to the club
 

·
Premium Member
Joined
·
10,769 Posts
Congrats on the purchase... a great combination of massive style and great fuel economy... whether or not your Canadian! LOL
 

·
Registered
Joined
·
597 Posts
Discussion Starter #8
Thanks guys!

I'm having the same issue as another member a couple posts down. I can't activate PMs. I got more than 10 posts and I've been on at least once a day?

To be considered active for 10 days do you need to login or do you have to post? and it is for 10 days straight (so weekends, which I generally don't come on)

Thanks in advance,
Bryan
 

·
Registered
Joined
·
683 Posts
I think it's just 10 days from the day you registered but it is down to the second. If you still can't PM try logging off and then log back in. That is what I had to do.
 
1 - 10 of 10 Posts
Top