Chrysler 300C & SRT8 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
Put a set of 275/40/20's on the rear of my SRT8. While I love the look, feel and ride of the tire, I'm not a fan of the noise when the rubber breaks loose in any way. The tires squeal easy from a traffic signal which draws a lot of attention at an intersection and beyond. It's super easy to get a loud squeal from the tires on a hot day especially when going over the white painted stop lines in the road and I look like a jackass when it happens... thing is I'm not accelerating that hard. The stock F1's wouldn't make any noise if they broke loose. I'm running about 32psi in these Proxes. Anyone else with these tires... will this noise go away after they break in or what if I bump the tire pressure up a bit? If nothing works, these are going on the front (if they fit) and I'm getting something else of the rear, I'll get pulled over withing a month with the noise this car gets out of these tires.
 

·
Registered
Joined
·
683 Posts
I have the same setup on my car and no problems with them. They will break away if I get on it coming off a stop but with the ESP on and just doing a normal easy acceleration they don't break away at all. It's been over a 100 for the last 3 weeks here as well so I'm running in the same conditions. My pressure is at 33 psi according to the TPMS. I found it way easy to squeal my F1 but not the toyos. Maybe back off on the pedal some when the light goes green.
 

·
Registered
Joined
·
426 Posts
Did you get the tires about the same time you got the predator, because when i put in the predator my car would spin the tires starting out and when shifting to next gear in auto, with the esp on.
then when i put the magnaflow high flow cats and corsa catback on, it stopped spinning the tires so easily starting out, And now i seem to spin them whenever i jump on it at anything less than 50 mph.
 
1 - 3 of 3 Posts
Top