Chrysler 300C & SRT8 Forums banner
21 - 25 of 25 Posts

·
Registered
Joined
·
652 Posts
If it’s an aftermarket HID kit there might be an inline fuse that is part of the kit and not in the car fusebox.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
2 Posts
I know this has been covered in the forums but the more I read the more confused I get.
I have a 2007 5.7L 300c.
A few months ago my left headlight went out. I went to my local car parts store and they gave me a price of $400 for a replacement bulb! (I live in New Zealand so we get ripped off down here). The old bulb is a DiS 35w from Osram.
I decided to get a new pair of xenon bulbs from Ebay for about US$50.

I replaced both bulbs but they flickered heaps and sometimes the left one would turn off completley. Now the left one wont work at all. I tried plugging in one of the orginal Osram bulbs (the good one) and that wouldnt work either, I swapped the bulbs around and still no go.

Im guessing my ballast is broken? Im worried if I buy an OEM Ballast the new xenon bulbs will stuff it up. At a cost of NZ$900 for one ballast I cant be getting it wrong.

So now Im thinking of getting a HID Kit with bulbs and ballasts from Ebay. They seem to go for around US$100.

To add to the confusion I asked a seller on Ebay if his kit was a simple plug and play install for my 300c, he replied by saying I may need a canbus?? :headache:

Ive also read that the ballast is attached to the OEM Bulbs?

If someone can help me out here I'd be so thankful!

Also, how many ballasts do 300c's have? Are there seperate ballasts for high beam, low beam, park lights and fog lights? If I'm taking my front bumper off to get to the ballasts I may as well replace my fog lights too but if thats going to be a mission I'll forget it.
Try your light switch inside of the car. Pulls out easy and cheap.
 

·
Registered
Joined
·
1 Posts
I have a 2007 300C. The passenger side headlight burned out. That light stays on all the time. Never changed the bulb, until this issue came up, tried the key dance, replacing bulbs, I even did the rain dance, drank watwr though a staw standing on my head and was actually able to rope the wind! All to no avail. I put a new headlight bulb in, car is off, l I gbt switch is off, but, alas, that rightbs I de headlight stays lit! WTF? Any one have this problem? Besides hundreds of dollars at the dealership, any one have any insight????
 

·
Registered
Joined
·
1 Posts
ya that sounds like a ballast issue...i say go aftermarket. i swapped to a d2s kit which is much cheaper to replace if anything ever goes wrong again. just need an adapter so the bulb will be held in place properly. definitely don't get the oem ballast from the dealer tho. i found some d1s bllasts when i replaced the first oem one that went out on mine for about $150
Hi my name is Jim.If I could put my 2 cents in it may help someone out.My old neighbor brought me his 08 chrysler 300 for the same related issues.I found a broken ground wire back behind the headlamp were the grounds come together.Look and inspect very closely if there is any corrosion clean the area and ground loop.Also did that and high beams wouldn't work.Turns out the connection going to the bulb is bad had to giggle the two wires and it came back on.I hope this helps someone.
 
21 - 25 of 25 Posts
Top