Chrysler 300C & SRT8 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Its been over 100 degrees here the past few days. my car got hot yesturday almost to red levels. this morning i had added the lost coolant which was at min level. had not lost too much. turned on my car and let idle after it was at normal temp it stayed there for little while so i turned the ac on and and after a few mins it started to rise again and had lost the cooland i added. seems i lost alot for the little amont of time but i think it was just evaporating. when i turned the engine off i could hear a little hissing noise coming the front of the engine compartment near the radiator. after letting it cool enough i let the remaining pressure out from the cap and the hissing stopped. i noticed coolant on the splash guard, cooling fans, altinator, front of the engine, it was fine pink residue not liquid anymore. did oil change this morning also and the oil looked fine. took a pic i dont know if it help too much.
 

Attachments

·
BLOODY ADMENSTRUATOR
Joined
·
12,606 Posts
The cooling systems on these cars are pretty much standard design and components for front engine, rear drive cars.

Doesn't seem to be any real weakness, as many members here have racked up high mileage.

That being said, cooling systems on any car are an area of wear and tear.

Sounds like there is a leak in the system. Not really necessary to go to a Chrysler dealer. But, it might be an idea to get it to a good rad shop so they can put a pressure test on the system and find the source of the leak.
 

·
Registered
Joined
·
1,140 Posts
Yeah it does. i hope it is just that. looks like i pick a new up for around $100.

thanks
well pick up a good quality one a lot of places like auto zone will give you a life time warranty and when you change it replace clamps and hoses with new also use only zerex G-05 (HOAT) or equivalent coolant you can get it just about anywhere.
 

·
Registered
Joined
·
1 Posts
Mine is doing the same thing! exact same issue can you tell me what you had to replace and if i can do it myself?
 
1 - 7 of 7 Posts
Top