Chrysler 300C & SRT8 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I recently had to change one the the aftermarket LED headlight bulbs I bought after I purchased the car last June. I purchased a set off of Amazon. I installed them and they both worked for a few days. After about two days I noticed while I was driving that the passenger side was cutting on and off. It wasn't blinking or flickering. It would stay off for a few seconds or sometimes a few minutes. I ordered a new set of the same bulbs and installed those. The passenger side didn't work at all now. Never came back on. I tested it with my meter, no power. Driver side has 12 volts. I check the fuse boxes, I see that I have no fuses or relays in the sockets marked for my headlights......WTF!!!??? How the hell are all the other lights working and this one socket ain't working. And furthermore, how the hell are all my lights working with no GD fuses or relays???? Please help y'all. I kinda need to see when I'm driving at night. Plus FTP!!
 

·
Registered
Joined
·
1,507 Posts
The best tool for diagnosing this problem is AlfaOBD. You can go into test mode and manually toggle every lamp on and off individually via the Body Control Module, then check for 12v at that time. Also, AlfaOBD will read BCM fault codes and allow you to make configuration changes. You might find lamp error codes, or you might find the LED lighting performs more reliably if you change the configuration for "LED headlamps" to "Enabled".

What's "Plus FTP"?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
The best tool for diagnosing this problem is AlfaOBD. You can go into test mode and manually toggle every lamp on and off individually via the Body Control Module, then check for 12v at that time. Also, AlfaOBD will read BCM fault codes and allow you to make configuration changes. You might find lamp error codes, or you might find the LED lighting performs more reliably if you change the configuration for "LED headlamps" to "Enabled".

What's "Plus FTP"?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
The best tool for diagnosing this problem is AlfaOBD. You can go into test mode and manually toggle every lamp on and off individually via the Body Control Module, then check for 12v at that time. Also, AlfaOBD will read BCM fault codes and allow you to make configuration changes. You might find lamp error codes, or you might find the LED lighting performs more reliably if you change the configuration for "LED headlamps" to "Enabled".

What's "Plus FTP"?

I have an electrical background and Im pretty confident that I can find the problem after a few minutes of troubleshooting. I was just trying to get some answers as to why I'm not seeing the fuses or relays where they should be. It just doesn't make sense. Also, "FTP" means **** The Police. But I was just saying that because with one of my headlights not working I'd most likely get pulled over and given a ticket and I don't want that to happen
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top