Chrysler 300C & SRT8 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1 (Edited)
Hey guys,

wanted to post a link to a video of my engine idling. I'm not sure what exactly I'm listening for for a healthy idle, but to me it seems like there is more of a metallic clicking sound coming from the engine than in years past. I'm not sure. When the camera gets close on the drivers side bank of cylinders you can hear more of it. The car runs well, has been recently seafoam'd (not that huge an amount of smoke came out but reasonable (video coming). The idle is good and the engine never dies or anything. In fact while doing the throttle body spray the engine smoothed out a bit and was easier to hold the rpms at 1500.

Chrysler 300c SRT8 6.1L Idle Engine Noise Download - YouTube

Any wise wizards around please take a listen and play the video in HD for best quality audio.

Car is stock (no Diablo yet), has a CAI, and Corsa Cat-Back. I'm mainly concerned about the engine sound and the lifters, etc. Any help on what to be listening for would be great as I want to keep my ride as long as possible, I'm at 7 years and 70,500 miles.

Car doesn't break loose the tires as much as it used to, but that could be the Toyo Proxes 4 Plus tires I put on less than 3,000 miles ago. Hard to say. Butt Dyno is also un-sure.

THANKS I LOVE THIS FORUM AND I THANK YOU ALL FOR YOUR INSIGHT. This is a newer screen name because I had an old e-mail I can't access for the older one. My stats are low on this one but I'm not a drive by poster !! THANKS

_FASTINFLORIDA :fing02:
 

·
Premium Member
Joined
·
4,708 Posts
Injectors?
 
  • Like
Reactions: FASTINFLORIDA

·
Administrator
Joined
·
19,734 Posts
Sounds like an injector fault to me. Try swapping them over to opposite sides or pull the that seems to be making the largest amount of noise and swap it to the other side, then listen again.

Also, it could be a small exhaust leak at the manifold flange.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
Hard to pin down

Thanks guys,

any way to visually inspect the injectors ??

As you can see in the video the ticking gets much louder there on the drivers side, but overall I can't tell if it sounds WRONG, or what. It just seems to be making more of a clicking sound than I would like.

Suggestions for maintenance ?? replace the injectors ?? I can do most basic maintenance but I'm not a big wrench guy. I would rather take it to someone who does this all the time than me take 4 times as long to do it and risk dropping a nut or washer or something in the wrong place. That said I'm not afraid to turn a wrench but there is only so far I will go.

It does sound WRONG though right ?? Not catastrophic but not great. I just did a full treatment of Seafoam (throttle body sprayed), 1/3 or so can in the crankcase (drove it 50 or so miles and immediately changed the oil), and put some in the gas tank also.

Should I give Techron fuel system cleaner a go on the next tank ?? (before I go wrenching)

THANKS GUYS:arms:
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
0-60

I'm still getting 4.9 secs on the 0-60 timer in 90 degree florida afternoon heat. Back when I first got the car and still had the F1's I would consistently pull 4.6secs

THANKS
 

·
Administrator
Joined
·
19,734 Posts
You can try a bit of injector cleaner. Something may have come loose during the cleaning and stuck with the injector.

Don't start throwing parts at it until you isolate the problem. If it still clicks after some injector cleaner in the tank (run a full tank of fuel through the car), then try to pin down what injector is clicking and swap it over to the other side and run it again.
 

·
Premium Member
Joined
·
512 Posts
On top of what the others have said, here's a tip for identifying a noisy injector.

Under the hood, it's hard to hear exactly what is going on in a given spot when everything else is making noise. Grab a long screwdriver and place the tip of the screwdriver against an injector. Then, put your ear up to the handle of the screwdriver. This will allow the vibration of each individual injector to vibrate directly onto the screwdriver and into your ear.
 

·
Premium Member
Joined
·
6,058 Posts
If you just seafoamed it where did you pour it? Did you do fuel, oil and vacuum? If so then you've already cleaned the injectors... It does sound injector related as well... maybe you have one still a little gummed up and I'm with Maddog on doing another injector treatment. Did you dump the oil after seafoam? My Brother in Law did a Bronco with a 5.0 and after (week or so) he brought it to me as it was clattering like mad, sounded like lifters collapsing to me so we changed the oil (first time since seafoam) cleared it right up... I put it down to the seafoam broke down the oil viscosity, even though it claims it won't. Also I too hear a little tick like a leaking exhaust manifold gasket...
 
  • Like
Reactions: FASTINFLORIDA

·
Registered
Joined
·
103 Posts
Discussion Starter #9
If you just seafoamed it where did you pour it? Did you do fuel, oil and vacuum? If so then you've already cleaned the injectors... It does sound injector related as well... maybe you have one still a little gummed up and I'm with Maddog on doing another injector treatment. Did you dump the oil after seafoam? My Brother in Law did a Bronco with a 5.0 and after (week or so) he brought it to me as it was clattering like mad, sounded like lifters collapsing to me so we changed the oil (first time since seafoam) cleared it right up... I put it down to the seafoam broke down the oil viscosity, even though it claims it won't. Also I too hear a little tick like a leaking exhaust manifold gasket...
Hey guys,

yes I put Seafoam in the crankcase, fuel, and did the spray thru the throttle body. I did not do the vacuum line. I ran the car for about 40-50 miles, then changed the oil. This video was before the oil change and while the Seafoam was in it. I haven't ran the whole tank with the Seafoam thru yet, I will finish this tank, and give some Techron a go.

I never really noticed before but I agree there seems to be a small manifold leak on the drivers side. Something to be that concerned about ?? Should I let it slide for a while ??

Thanks y'all :biggrin:
 

·
Registered
Joined
·
171 Posts
Hey guys,

wanted to post a link to a video of my engine idling. I'm not sure what exactly I'm listening for for a healthy idle, but to me it seems like there is more of a metallic clicking sound coming from the engine than in years past. I'm not sure. When the camera gets close on the drivers side bank of cylinders you can hear more of it. The car runs well, has been recently seafoam'd (not that huge an amount of smoke came out but reasonable (video coming). The idle is good and the engine never dies or anything. In fact while doing the throttle body spray the engine smoothed out a bit and was easier to hold the rpms at 1500.

Chrysler 300c SRT8 6.1L Idle Engine Noise Download - YouTube

Any wise wizards around please take a listen and play the video in HD for best quality audio.

Car is stock (no Diablo yet), has a CAI, and Corsa Cat-Back. I'm mainly concerned about the engine sound and the lifters, etc. Any help on what to be listening for would be great as I want to keep my ride as long as possible, I'm at 7 years and 70,500 miles.

Car doesn't break loose the tires as much as it used to, but that could be the Toyo Proxes 4 Plus tires I put on less than 3,000 miles ago. Hard to say. Butt Dyno is also un-sure.

THANKS I LOVE THIS FORUM AND I THANK YOU ALL FOR YOUR INSIGHT. This is a newer screen name because I had an old e-mail I can't access for the older one. My stats are low on this one but I'm not a drive by poster !! THANKS

_FASTINFLORIDA :fing02:
Hi Fast,

Hmmm, i beleive i have some similar sound from my engine. Not as heavy as yours, but its there... Its this metalic sound like valves needs adjustment (like on good the old cars). Mine does have a slight bad idle tho... It feels like it "missing" a spark from time to time.
Anyway, the sound is the same i beleive, and im suspecting either valve spring or bad injector. Have not had this confirmed yet because its not causing any problems at the moment, but going to in near future!!
And As desiree wrote, might be the injector???
 

·
Premium Member
Joined
·
6,058 Posts
Don't forget guys... most... if not all Hemi's tend to have a 'Hemi Tick'... yours Fast is a little louder and a little different to that though. Give it some time and a little more injector cleaner if you feel it necessary and see if she quietens up any. As for the manifold leak, it can only get worse if it's there... might be worth checking sooner rather than later as it may just need the bolts snugged up again or at the worst a new gasket.
 

·
Registered
Joined
·
171 Posts
Don't forget guys... most... if not all Hemi's tend to have a 'Hemi Tick'... yours Fast is a little louder and a little different to that though. Give it some time and a little more injector cleaner if you feel it necessary and see if she quietens up any. As for the manifold leak, it can only get worse if it's there... might be worth checking sooner rather than later as it may just need the bolts snugged up again or at the worst a new gasket.
Yeah i know about the tick... But like fast (same sound only slightly lower) i have a clear metalic like clacking from left side of engine... Sounds like the valves need adjustment (like the good old cars) and since i also have a little rough idle im figuring its not the hemi tick?
 
1 - 12 of 12 Posts
Top