Chrysler 300C & SRT8 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey, I'm new to the forum. But I'm having trouble with my 300c. I took the car to the dealer for oil change and I think they put 5w 30 in it. Instead of the synthetic I was running . The car is now putting on throwing a oil pressure code . Is the engine to the point of no return?
 

·
Registered
Joined
·
2,561 Posts
Welcome to the forum!

My understanding is that running synthetic 5w30 won't kill your motor; MDS may not work correctly, though. Are you sure it was standard oil and not synthetic? I can't believe the dealer wouldn't use synthetic, let alone the correct oil.... I would take it back and have them change it to 5w20. What was the code number? I would imagine that standard oil may trip a fault code, then. Someone else may know more here, but synthetic 5w30 won't hurt your motor; I doubt standard oil would either in the very short term. Call your dealer tomorrow...
 
  • Like
Reactions: 17thstShizz

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It threw a misfire code and oil pressure sensor code , I think they put non synthetic oil in . And it's super thin. Motor sounds like it's taping now.
 

·
Premium Member
Joined
·
6,058 Posts
Sounds like it's the wrong oil, when mds is activating its cutting spark when appropriate as it shuts down the corresponding cylinder, problem is the lifters can't do there thing as the viscosity is too thick, so it just misfires... plausible.

Usually it happens with something thicker than 10/30 though, so that's a little odd. Either way it's on them and take it in and see if it sorts the issue!

Damn stealerships....

Sent from AutoGuide.com Free App
 
1 - 6 of 6 Posts
Top