Chrysler 300C & SRT8 Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
Bought the posi's based on overwhelming positive feedback. Installed them last week. No brake dust but noticed today that they squeek at very slow stopping speeds :pat: WTF?

I have beded them not as hard as they suggest but at least five times. Any suggestions.

Also, The place I had them installed has done allot of work for me but they would not warranty against noise or vibration. He did say that he really likes the pads and has installed them on several vehicles.
 

·
Registered
Joined
·
771 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #3
I will try and bed them ASAP. Hope it works!

P.S. No brake dust 5 days after a wash..... I almost don't care if they make noise!
 

·
Registered
Joined
·
771 Posts
Nope, that is Uga the University of Georgia's mascot and I agree about bulldogs!
 

·
Registered
Joined
·
1,228 Posts
shark bro be patient man
 

·
Registered
Joined
·
122 Posts
Discussion Starter #8
You ever notice how hard it is to be patient??

I am sure they will work out!!
 

·
Registered
Joined
·
1,228 Posts
ya if i dont workout in the mourning i pace all day long
 

·
Registered
Joined
·
903 Posts
Its the rotors. I have the posi quiets too. I replaced my original pads at 21,000 miles. My rotors were worn and I thought I had ridden my original pads to metal. After pulling them off they still had about 35% left. I put the posi quiets on. Love them. But now 10,000 miles later my rotors are really shot. I believe these brembos are too much for these soft rotors.
 

·
Registered
Joined
·
1,228 Posts
my posi's are quiet
 

·
Premium Member
Joined
·
1,008 Posts
Put my Posi's on with brand new rotors last week (dealer supplied third set of rotors!) and did not even bed them yet, they are absolutely silent and still stop well.
 

·
Registered
Joined
·
456 Posts
I had them for couple of months they were good & quiet but as for performance they were not as good as stockers.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #15
Have not heard the brakes sqeek for the last couple of days... Could have something to to with the Magnaflow exhaust!!!!
 

·
Registered
Joined
·
622 Posts
I just installed my new pads from Zeckhausen today.

I'm Very Pleased.

I washed the inside of the wheels and tires too.

I bedded them also and they work perfectly.

After 5+ very hard stops, I got home expecting the dust to be all over the place but there was none! Yeah!!!

I almost can't notice that I changed them, except for the lack of brake dust.

Thanks 300Cforum for letting me know about these brake pads, I should have done this a year ago!:smashfrea
 

·
Registered
Joined
·
903 Posts
Where did you order from?
I paid $92 for front and rear posi queits pads (all for wheels) off ebay shipped. The seller was rotorworks. It was more for me since they charged sales tax to ca bidders.
 

·
Registered
Joined
·
1,228 Posts
I paid $92 for front and rear posi queits pads (all for wheels) off ebay shipped. The seller was rotorworks. It was more for me since they charged sales tax to ca bidders.
zachs charges like twice that arrrrr or do you mean 92 rear and 92 front?
 
1 - 20 of 23 Posts
Top