Chrysler 300C & SRT8 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
803 Posts
Discussion Starter #1
I'm confused on how to set the fans on my car to keep it below 200. I've got the thermostat and the predator but there's just too many options for fan settings. It's scary. I want my mommy.
 

·
Premium Member
Joined
·
4,708 Posts
I'm confused on how to set the fans on my car to keep it below 200. I've got the thermostat and the predator but there's just too many options for fan settings. It's scary. I want my mommy.
First, there are only two fan speeds (other than "off"): low and high. So, whereever you need an input for medium speed just use the high speed figure.
Second, for all three conditions (if I recall correctly: low highway speed, high highway speed, and A/C on) use the same values for the fan settings.
Third, according to the folks at Diablo Sport, the fans switch off 10*F below the the temperature at which they switch on.
I am using the AutoZone 4128 t-stat. I know that the coolant runs 185/186*F all day in cool ambient temperatures at highway speeds. So, I set my low speed "fan- on" temperature at 197*F to allow the the fan to actually shut off. Any lower and you run the chance of the fan never shutting off. I set my middle and high speed "fan-on" temperature at 207*F.
That's it in a nutshell. Not too bad when you distill it all down.
Now all you have to do is toggle the Predator's menus and set the temps.
 

·
Registered
Joined
·
1,317 Posts
yep..I have mine set the same....however mine still goes above 200 in S.Fla. It hardly every get above 210 even w/aggressive driving.

Hi/Med - 207
Lo - 197
 

·
Registered
Joined
·
9,851 Posts
if you have downloaded the latest revision from Diablo(9r04)then leave fan settings alone,they have listened to the public and done the work for us,the settings are all 200F plus(I think,without checking)and they for once are working A1
 

·
Registered
Joined
·
1,283 Posts
if you have downloaded the latest revision from Diablo(9r04)then leave fan settings alone,they have listened to the public and done the work for us,the settings are all 200F plus(I think,without checking)and they for once are working A1

...this is not exactly correct. Mine ran way hotter after the update, 1/2 way. I have since adjusted mine to 197 ls and 207 hs. Much better. Gets to 1/4 temp fan kicks in for 20-30secs bingo. Perfect.
 

·
Registered
Joined
·
278 Posts
The latest version has the fan speeds set to stock, the earler versions were set perfect in my view..
 
1 - 7 of 7 Posts
Top