Chrysler 300C & SRT8 Forums banner
1 - 20 of 40 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hi,

just curious if anyone else has had this issue, started last week...
whilst driving with the radio on it has started cutting out(seems to loose power) then come back on a few seconds later, whilst it turns itself off the rear reverse sensor lights all light up, then go out again when the radio turns back on. (very very odd)
Anyone had this problem or have any suggestions? its starting to become a little irritating to be honest..:pat:
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
i think its are issue from the HID Translator Modul, disconnect the plug, drive some day and you well see its all good.





thats really odd, unplugged it than plugged it back in and went for a drive - it appears to have sorted it ?!?! cheers.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
hi

sorry dont understand.......have you remove the plug and drive some days ..? (


No, I removed the plug, then refitted it and the problem hasnt happened since... maybe I havent driven it enough yet, I dont know.
 

·
Premium Member
Joined
·
1,299 Posts
No, I removed the plug, then refitted it and the problem hasnt happened since... maybe I havent driven it enough yet, I dont know.

look


for checking rigth you must remove the plug and drive some day , without it.....but its no problem!


this modul when have issue make many canbus problems.....
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #9 ·
you were right, it has not cured the problem, I will disconnect the plug and use the car for a couple of days this week and see if it stil happens.
If disconnecting the plug solves the problem does that mean I need to replace the HID Translator Modul ??
 

·
Registered
Joined
·
170 Posts
My 300c has the exact same problem!
It does it completely at random, and disconnecting the HIDT plug made NO difference at all. When it does it a lot the Park Sensors eventually ping up a "Service Park Assist" warning on the EVIC, so I removed the boot trim and disconnected the Park Assist ECU, thinking maybe it was this causing the fault. Guess what, yes, the next time I drove it the original fault was still there!
Sometimes it will go for days and days without doing it, then just when you think it's sorted itself out, it goes and does it again! I also discovered the indicators, if on, will stop flashing momentarily at the same time.....
I hope someone comes up with a cure for this as it is driving me nuts and I will/can not trust my local dealers (40 miles and 85 miles)! A small fire and insurance payout would be a bonus as far as I am concerned with this joke of a car right now!
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 ·
i have done 600 miles with it unplugged and the radio has worked perfectly...
does this mean that I need a new module?
 

·
Registered
Joined
·
170 Posts
Well, after driving for nearly 2 weeks with no issues, it did it again 3 times between starting up and getting to the bottom of my drive, a distance of 15 metres! I opened the bonnet and pulled the HIDT plug and it hasn't done it since!! This weekend I will remove the right boot trim and reconnect the rear park assist ecu and HIDT and wait for it to do it again, then disconnect just the HIDT. My only worry with this is losing headlight levelling when turning on the headlights, and dazzling people.......
 

·
Registered
Joined
·
170 Posts
Update. The HIDT Module is still disconnected, the radio and park sensors have been perfect now since disconnecting it on the 31st of August!
The funny thing is, my headlights still do their little height dance at switch-on, and they still auto-level when a load goes in the rear or the car alters attitude due to either heavy braking or acceleration..... so what the heck does the HIDT actually do, because everything seems to be working as normal with it disconnected...?????
 

·
Registered
Joined
·
2,416 Posts
Hi, See below

It looks as though lights will still "Do the Dance" but may not level under load and will not store trouble codes ???


HIDT Description

The Headlamp Leveling Module or HID Translator Module is the remote electronic sub-component of the headlamp leveling system. The HID translator module is used to translate communication of the headlamps leveling system. The sensors communicate over a K-Line to the headlamp stepper motors, then to the translator module. To enable the scan tool to read system inputs and outputs, and to retrieve Diagnostic Trouble Codes (DTC's), the translator module must convert this K-Line data into Controller Area Network (CAN) data.

HIDT OPERATION
The system is designed to automatically level the vehicles headlamps, regardless of cargo or passenger loads or road conditions. When the vehicle is loaded with passengers and/or cargo, as the ignition is turned to RUN, the system will look at the front and rear sensors and make an adjustment based upon feedback from the sensor to see if it has approximately 27.5 degrees from its zero or neutral position. The headlamp stepper motor then adjusts the headlamp up or down for proper headlamp aiming. The system is dynamic. The headlamp level will be adjusted while driving if required based on sensor inputs.

NOTE: If the headlamp leveling module (HID translator module) or sensors are replaced, the system needs to be calibrated using a Scan Tool.

When in calibration mode, the key in the RUN position, the vehicle doors, trunk/liftgate, and hood must be closed. In addition, no one is seated in vehicle, the vehicle may not be touched (bounced or bumped) until the calibration is complete. The headlamps must be ON to power the stepper motors. The approximate calibration time is 12 - 15 seconds. The scan tool will display a “status of calibration” message. These being either “still in progress”, “passed”, or “failed.”

If a system fault occurs, the translator module will store the Diagnostic Trouble Code (DTC) and enable it to be read using the scan tool and assist in diagnosing the headlamp leveling system.
 

·
Registered
Joined
·
188 Posts
Not sure if I have something similar going on, but rear parking sensor (RHS) has started giving a false warning every time I reverse in the last 2 months or so, and another weird issue that used to happen once every few months when the car was newer, but is now happening virtually every time I use the car is that the instrument cluster seems to reset itself when driving.

Symptoms are that all dash warning lights will come on and MPH / RPM clocks will go to zero momentarily when driving, then all returns to normal and seems ok, engine & headlights etc never cut, so am assuming it is an issue with a poor earth or loose connection to the instrument cluster itself. Anyone else had anything similar?

Still pretty happy with the car after nearly 6 years, and yet again thinking of keeping for another couple of years - nothing out there I would replace it with really.
 

·
Registered
Joined
·
2,416 Posts
If you read this post carefully you will see the most likely fault is the HIDT translator module. See picture attached. Mounted in front Left of engine compartment behind headlight cluster.


You must try this first and see if it fixes it. Just unplug the module and drive with it disconnected for a few days.


Jack
 

Attachments

·
Registered
Joined
·
401 Posts
If you read this post carefully you will see the most likely fault is the HIDT translator module. See picture attached. Mounted in front Left of engine compartment behind headlight cluster.


You must try this first and see if it fixes it. Just unplug the module and drive with it disconnected for a few days.


Jack
Just tried that myself.
park assist works intermittantly sometimes showing just 4 reds then while reversing it comes back as it should.
next reverse it may or may not work at all.
had the rear bumper off and cleaned all the plugs and sensors and checked the wiring loom for damage.
i suspect one may be down and only working occasionally.

Last option now is the park assist module itself.

Can someone confirm it is behind the rear o/s load bay trim on a touring ?
 
1 - 20 of 40 Posts
Top