Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just bought a 2014 Chrysler 300C 5.7 Hemi AWD. I absolutely love it minus the fact that it just started acting up and I can't seem to come up with a logical reason as to what is going on. Here's the issue.

Every now and then the car will randomly make a popping noise and you can feel the vehicle slightly jerk whether your accelerating, cruising, or decelerating. To get a little more descriptive, it feels like the car is stalling very briefly, but it doesn't effect the RPMs on the tach at all or throw a check engine light. It seems to happen more often when you're cruising or slowing down rather than accelerating, but it has happened when accelerating as well, just not as often. Also, I've done a "test"...so to speak, by speeding up and putting the car in neutral and coasting to see if the pop/jerk will occur while the transmission is not engaged, which it didn't. Which leads me to believe that it is somehow transmission related...but I'm no expert.

I first noticed this shortly after buying the car, but it was very infrequent. Now it seems to be happening more often and getting worse. Can anyone help me out with this issue?
 

·
Registered
Joined
·
256 Posts
I just bought a 2014 Chrysler 300C 5.7 Hemi AWD. I absolutely love it minus the fact that it just started acting up and I can't seem to come up with a logical reason as to what is going on. Here's the issue.

Every now and then the car will randomly make a popping noise and you can feel the vehicle slightly jerk whether your accelerating, cruising, or decelerating. To get a little more descriptive, it feels like the car is stalling very briefly, but it doesn't effect the RPMs on the tach at all or throw a check engine light. It seems to happen more often when you're cruising or slowing down rather than accelerating, but it has happened when accelerating as well, just not as often. Also, I've done a "test"...so to speak, by speeding up and putting the car in neutral and coasting to see if the pop/jerk will occur while the transmission is not engaged, which it didn't. Which leads me to believe that it is somehow transmission related...but I'm no expert.

I first noticed this shortly after buying the car, but it was very infrequent. Now it seems to be happening more often and getting worse. Can anyone help me out with this issue?
ahoc77,

I'm sorry to hear about your concern.

You mentioned the symptom is becoming more frequent. How often does it occur? Will you be able to demonstrate the issue for your Chrysler dealer?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi there, thanks for the quick response. I haven't brought it in yet in fear that I wouldn't be able to replicate as it was quite infrequent when it first started. I'm becoming more confident that I will be able to replicate it lately as it seems to happen almost every time I drive it now. I'd say on average it happens randomly about 5-10 times every 10 minutes with varying intensity.
 

·
Administrator
Joined
·
19,617 Posts
If it is repeating itself that often then I'd be headed to the dealer.

Any Check Engine Light showing?
 

·
Premium Member
Joined
·
304 Posts
sounds like a pre ignition issue of sorts.this can be very serious.GET IT CHECKED ASAP!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Yup, I agree. I've got an appt. at the dealership this week. Gonna try not to drive too many miles until then. Nope..no check engine light at all. Thanks for the input everyone, I'll be sure to follow up after I have it checked out.
 

·
Registered
Joined
·
256 Posts
Hi there, thanks for the quick response. I haven't brought it in yet in fear that I wouldn't be able to replicate as it was quite infrequent when it first started. I'm becoming more confident that I will be able to replicate it lately as it seems to happen almost every time I drive it now. I'd say on average it happens randomly about 5-10 times every 10 minutes with varying intensity.
Yup, I agree. I've got an appt. at the dealership this week. Gonna try not to drive too many miles until then. Nope..no check engine light at all. Thanks for the input everyone, I'll be sure to follow up after I have it checked out.
ahoc77,

Being able to duplicate the symptom for the dealer will certainly be of benefit. Be sure to speak with the Service Manager if you have any additional questions while at your dealer as well.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Well I left it with the dealer all day today and picked it up just a little while ago. I immediately took it for a ride down the highway and there was the same problem that existed before...unfixed. Pop...pop...pop...happening about once or twice every mile. Before I dropped it off this morning I had taken one of the techs for a ride and I successfully replicated the problem many times and he agreed that something was wrong. Their "quick fix" was to update flash software pertaining to shift quality and a couple other module software updates (PCM and HVAC). They claimed they took it for a ride and confirmed they couldn't hear/feel the problem anymore. I definitely believe they drove it based on the amount of gas left when i picked it up, but the issue is still there, plain as day, and it's getting much worse and much more frequent. I'm banking on the fact that it's going to cause a major failure pretty soon, maybe I'm just too observant.
 
1 - 8 of 8 Posts
Top