Chrysler 300C & SRT8 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Good morning all,

As the title states I've got what feels like a sort of hop or clunk (no audio, just felt) coming from the rear end when I do any sort of aggressive launch/accel from a stand still. If I just accel normally it doesn't happen. Car is a 2011 300c, bone stock except for mishimoto catch can, 180 t-stat and a diablosport 93 octane tune.
 

·
Registered
Joined
·
225 Posts
Feel almost like it's driving sideways?
Do a close inspection of all your rear suspension components, diff mounts, and craddle mounts.

Sent from my SM-G988U using Tapatalk
 
  • Like
Reactions: tarheelcracker

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Feel almost like it's driving sideways?
Do a close inspection of all your rear suspension components, diff mounts, and craddle mounts.

Sent from my SM-G988U using Tapatalk
No doesn't feel like its driving sideways, just a sort of... thump maybe? I do have some heavyish things in the trunk but it only recently started doing this and the stuff in the trunk was there before it started.
 

·
Premium Member
Joined
·
249 Posts
What car and how many miles??
 

·
Registered
'05 300c Blondie
Joined
·
151 Posts
"...only recently started doing this and the stuff in the trunk was there before ..."

Don't doubt what you're saying, but would still suggest taking everything out... spare, jack, and anything else.. make sure the battery is secure and verify the clunk is still there with a few 'aggressive launches' . It'll only take a few minutes, and then there's no assumption.
 
1 - 6 of 6 Posts
Top