Chrysler 300C & SRT8 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi i have a 2005 300c and just noticed lately while accelerating hard from a stand still i hear a shudder sound coming from the rear, sound doesn't last long usually gone by the time i hit 60k, only happens on hard acceleration, otherwise i never hear it, Anyone else have this problem? what could it be? Thanks
 

·
Premium Member
Joined
·
6,058 Posts
^ could be...wouldn't that be more esp on cornering though Michael? My traction control, albeit rarely on, seems pretty quiet. Is it possible the rubber flex joint on the drive shaft is wearing out? Or even a beating somewhere...mine shuddered a bit when it tore...

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
85 Posts
I agree with silver06300c completely, but another cause could be the wheels aren't completely centered. They sell these little plastic dohicky rings on ebay that are suppose to center your wheel 100%. I got a set because I was having the same problem. They worked, like $10.00 bucks and it was gone. guess they act like a cushion or something. Hope this tid-bit helps.
 

·
BLOODY ADMENSTRUATOR
Joined
·
12,606 Posts
It could also be the rubber bushings that space the rear floating cradle as it mounts to the rear subframe.

Those bushings will deteriorate with time and allow the entire cradle to move around a little bit under hard acceleration, cornering and braking.
 

·
Registered
Joined
·
85 Posts
NORTHERN has a good point too. Sounds like it's time to get it up on a lift and check it out. That way you can put your hands on everything and see what could be causing it. Good luck
 

·
Administrator
Joined
·
19,737 Posts
I'd forgotten about the cradle bushings. My stock ones were terrible at only 12K miles. I put in Pedders bushings and sorta forgot about it as that took care of that problem!
 

·
Administrator
Joined
·
19,737 Posts
^ could be...wouldn't that be more esp on cornering though Michael? My traction control, albeit rarely on, seems pretty quiet. Is it possible the rubber flex joint on the drive shaft is wearing out? Or even a beating somewhere...mine shuddered a bit when it tore...

Sent from AutoGuide.com Free App
hmmm...yeah it could be that as well except he said he was experiencing it from a dead stop. I don't think you can corner from a dead stop, can you? ;)
 

·
Premium Member
Joined
·
6,058 Posts
hmmm...yeah it could be that as well except he said he was experiencing it from a dead stop. I don't think you can corner from a dead stop, can you? ;)
Hahaha! I know right! I was saying the esp is what you feel as a 'thunk' on my car, the traction control just kinda pulls power....so when you said about traction control I was thinking in mine the esp would be all you'd feel, so as this was from a stand still I don't think it's traction control related.

Now...back to these cradle bushings... what were your symptoms Michael? My car has a vibration I haven't been able to fix for a long time, thought it was tires, nope... switched the coupler... nope... whole diff and axles and hubs....nope...I gave up! Wonder if it could be bushings?!

You guys may be fixing my issue here as well! Lol...

Sent from AutoGuide.com Free App
 

·
Administrator
Joined
·
19,737 Posts
A small vibration was felt but what I really noticed was that the rear end "wagged it's tail" under acceleration, kinda side stepped if I hit an expansion strip in a corner and generally felt rubbery and disconnected.
 

·
Premium Member
Joined
·
6,058 Posts
A small vibration was felt but what I really noticed was that the rear end "wagged it's tail" under acceleration, kinda side stepped if I hit an expansion strip in a corner and generally felt rubbery and disconnected.
Holy crap! That's my car! Like it has a bad alignment or something, never felt this way before!! It's pointed but not 'predictable'... I'm going to have to check then out for sure!

Thanks guys...back to the op..any updates?

Sent from AutoGuide.com Free App
 
1 - 12 of 12 Posts
Top