Chrysler 300C & SRT8 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
well i ordered the mopar fog light kit for my base model and installed it yesterday morning, later on in the day i found out that as i made a right turn the blinker on the dash was blinking faster than usual so i tought ok, either the front or rear light bulb just died so i parked in autozone and saw that it was my rear that went out, bought a new light bulb and changed it and NOTHING:pat:! still the same so i looked closer at the original bulb and noticed that its in good condition so its not the bulb that needed to be changed. note that i recently installed the mopar foglight kit and have not taken it to the dealeship so they can program the fog lights to work. the rest of the lights work fine but the front right blinks faster and the right rear doesnt blink at all. the main problem is that the rear right doesnt blink when turning, if i turn the headlights on the rear right lights on just as it should but does not blink when turning. its not the fuses because i already checked as well. could i be looking at a simple problem due to the fog lights not being programed or could it be worse has any base model owners have had this happen to them? or anybody have some knowledge on this anything would help.
 

·
Registered
Joined
·
979 Posts
this is a weird problem you checked the fuses under the hood right? and the fuses in the trunk? I added reverse light in to my car and doing so caused a fuse under the hood to blow because there was now a bigger draw. For me the simple solution was to up the fuse 10 amps. Problem solved..
 
1 - 2 of 2 Posts
Top