Chrysler 300C & SRT8 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
NE ADVICE on my 300....wife and kids where driving on the freeway when all of a sudden car cut out ....i looked up the signal and it said electronic throttle control...and scan tool says p0430 ....any advice ....please help
 

·
Administrator
Joined
·
19,626 Posts
P0430 = Catalyst System Low Efficiency Bank 2. In plain english that means that one or more of the following conditions exist:

1. Exhaust Leak
2. Engine Mechanical Condition - oil or unburnt fuel in exhaust stream
3. Aging catalytic converter
4. Failing O2 sensor

A Chrysler tech can scan for each of these conditions to narrow it down.

How many miles on your car?
 

·
Premium Member
Joined
·
6,769 Posts
Do you have high flow cats by chance?
 

·
Registered
Joined
·
194 Posts
Red "thunder bolt light"? That sounds like an electrical warning such as if your alternator were failing or battery were under voltage. The "check engine" light is amber. I don't think the code you read is related to the car 'cutting out' But if your battery wasn't charging and the voltage dropped too low, that could make it stop.

When you say you "looked up the signal", how did you look it up, and how did you read the code?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
@ mad dog...thnx appreciate da info...due to da past holiday im takon da car in to a trusted mechanic who is goin to do a diagnostic...ill keep in mind the list uve givn me nd i hope ur right i read all kinds of forums nd they all sohnd similar to yours ....thnx alot

Oblivion....thnx for da help...i used a scan tool that told me when i plugged it to the car p0430 catalyst problem bank 2 ....then i ask.com the code nd looked at forums...
 

·
Registered
Joined
·
319 Posts
The red thunder light is for the throttle body. I had the same issue, while driving on the free way I would get that light and the car cuts off but stays running. After I reboot it works good for another 30 min and same thing again. I had to get a new throttle body and problem was fixed. Hope this helps


Moe Razak
Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thnx took the car in to get a diagnostics and techs said there was 3 issues gas pedal wasnt sending the right signal to the engine the spark plugs needed to be replaced and harmonic something....1200...smh
 

·
Registered
Joined
·
26 Posts
i have the same problem on my 06 300c and its at the dealer now getting fixed. it maybe the ignition relay to the ecu. when it dies on me i just put it in park take out the key put it back in and it will start right up. or should start up. i get the red lightning bolt, check engen and another light on. the code will not show unless you do it when it happeneds.
 
1 - 9 of 9 Posts
Top