Chrysler 300C & SRT8 Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi

I’ve had a bit of a read through the forum and have read some possible fixes that I will drive back to my work and try, but hoping someone may be able to assist me with the following.

I own a 2006 300C with a Varex/Xforce system. The system has never worked since purchasing my 300C, it remains in the open/loud setting. So this morning when I finished work and was returning the fleet vehicle, I thought why not have a look and try and find out what’s going on. Famous last words!

First up I discovered one heck of a dodgy wiring job which I have temporarily tied up until I can get down and purchase new connectors etc. The wiring appears to be piggy backed to the ignitions wiring harness. This wiring isn’t connected to anything other than what I am assuming to be the wiring harness to the ignition. Attached to the end of this wire is a small plug that appears to have a loose/broken connector. This I guessed would plug into the Varex smart box. I located the Varex smart box and found that, surprise, surprise, the damaged connector was indeed supposed to be plugged into the smart box. I temporarily fixed this connection and plugged it into the smart box, the box lit up, so I now know it works, or at least is getting power to it. I started the 300C up and tried to switch between the settings. Nothing. (I later found wires in the boot similar to the wires that run to the smart box. These were cut. Again, roughly, and again, no surprises going by the clowns handy work doing the wiring to begin with).

Learning that this was not going to be a simple quick fix situation, are they ever? Haha. I decided to leave it alone until I had all the bits and pieces that I needed to do the job properly, on hand. This is when I went to start the 300C up and head home. My 300C has never had any issues with starting in the time I’ve owned it. The dash lights, lights, radio etc. all came on, so did the ‘Service Park Assist’ warning.

Now my 300C is stuck at work unable to start. All electrics appear to be working fine. I’ve never had the ‘Service Park Assist’ displayed previously.
It’s almost like the battery is too flat to kick the starter over. This isn’t the case though as the battery is fairly new, and I tried jumping it to start. Nothing.

I’m at a complete loss as to what’s happened. It’s like the engine has been immobilised. Theres no clicking noises from the engine trying to kick, nothing.

If anyone can help with this I’d be super stoked. Thank you in advance, and thanks for taking the time to read my post.
 
1 - 1 of 1 Posts
Top