Chrysler 300C & SRT8 Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Has anyone experienced heavy steam comming out of the grill and hood front crease after driving in the rain? It seems like water collects somewhere between the grill and the radiator during driving in the rain, and then starts to evaporate from the engine heat.
 

·
Premium Member
Joined
·
1,151 Posts
albi said:
Has anyone experienced heavy steam comming out of the grill and hood front crease after driving in the rain? It seems like water collects somewhere between the grill and the radiator during driving in the rain, and then starts to evaporate from the engine heat.
Yes, several times, but not all the time. Strange...

I am not sure exactly where it is coming from...possibly water hitting hot exhaust components?
 

·
Registered
Joined
·
677 Posts
I get this too, but only at certain stoplights at certain angles. The offramp at my work does it consistently in the rain, but only at certain parts of the offramp.

I believe it has to do with rain hitting the radiator through my mesh grill? I dunno...
 

·
Registered
Joined
·
375 Posts
Mine does in the rain, or after I wash it (like this morning after it's 8am bath before I came to work.).
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 ·
I'm glad I'm not the only one with the problem. Can this be considered a design flaw? Can this cause problems with the radiator down the road. I mean, all that water boiling off the radiator cannot be that good for it, right?
 

·
Registered
Joined
·
375 Posts
I don't think it's a problem, my Camry did it in heavy rain also.
 

·
Premium Member
Joined
·
1,151 Posts
high groove said:
My radiator also steams! I know there is a TSB on it, but so far I have not noticed any problems caused from this happening.
Which TSB?
 

·
Premium Member
Joined
·
1,151 Posts
jcsganga34 said:
12/08/04 … 2005 .. #18-044-04 …. Cold Start Idle Cycling Or Radiator Steaming At Idle .. (3M)
Thanks, but something tells me this is not related to the 'rain' problem. I don't see steam any other time I am idling.
 

·
Registered
Joined
·
323 Posts
Yeah, I wasn't sure if it was the same issue or not. That is probably the TSB he was referring to though so I figured I would post. I too have noticed the steam but only during heavy downpours.
 

·
Registered
Joined
·
265 Posts
Yeah, I saw it do it once in heavy rain with the stock grill.. Have not had the E&G long enough yet....

Pretty normal, lots of cars do it if they get water splashed on the radiator, and I wouldn't worry about damage, those things are exposed to all kinds of sudden temp changes. That's why they're made of alum... Well, that and to help expel heat.... =)
 

·
Registered
Joined
·
14 Posts
My Mag does it right after a touch-free cw also. But only for 30 seconds or so.
 

·
Registered
Joined
·
101 Posts
same thing on my 300c, also traded a 2000 300m that done the same thing. just the cold water hitting the hot rad. no big problem i dont think.
 

·
Premium Member
Joined
·
3,499 Posts
wild bill said:
same thing on my 300c, also traded a 2000 300m that done the same thing. just the cold water hitting the hot rad. no big problem i dont think.
YUP! I noticed it too. Didn't give it a second thought as I had a 1981 Plymouth Reliant that did it too. It's simply rain or wash water running off of the hood at the front edge and dripping onto thr radiator.
 
1 - 20 of 23 Posts
Top