Chrysler 300C & SRT8 Forums banner

501 - 520 of 560 Posts

·
Registered
Joined
·
26 Posts
I've dropped them message on the bay about it so if they get back to me with any info Anthony I'll let you know what they've got to say about it, bit naughty it they sell it as full package so to speak yet you maybe have to download extra bits.
 

·
Registered
Joined
·
13 Posts
Ah ok.....
So, it was as I said, I think.
It did say found 2 faults and cleared them, but didn't identify the codes, that's a shame?

Sent from my SM-N910F using Tapatalk
 

·
Registered
Joined
·
26 Posts
Fault cont,

Hi all, well I got myself a reader and the code that came up was P0069, having cleared that successfully I restarted the car and for five seconds or so no lights and no noises and then the red lightning bolt check light appeared but no yellow engine check light! Still drives the same as though it's in limp mode so nothing seems to have changed, I have thoroughly checked for worn wiring but all is fine and according to the book that came with the scanner the code I have that keeps appearing is a map sensor! Can anybody advise me which direction to start looking in to sort that out please?
 

·
Registered
Joined
·
26 Posts
I'm sorted now it seems. I read an older post and 'JackWalton' had mentioned that code often applies to a sensor in the airbox so I swapped the box lid off the other car and it now runs really nicely once again no codes and no lights Yeehaa!! I'm going to leave the resistor in the swirl motor as it seems like the thing to do but would you all recommend that I bypass the EGR While I've got my hands dirty?? Is there a benefit in performance/economy or just leave it as it is if it's working? many thanks I would have been relieved of many pounds had I not had this forum to read and throw questions at :)
 

·
Registered
Joined
·
944 Posts
Hi Guys,
I have the swirl motor failure symptoms on my 2007CRD. After reading all these threads I am going to try the resistor "trick" as being quoted a ridiculous price to fix the motor. I have one question - which pins in the plug do I put the resistor in - seems to be 2 answers reading this thread.

COULD SOMEONE CONFIRM THE PINS PLEASE

Thanks in advance :)
 

·
Registered
Joined
·
55 Posts
Hi, I have tried with all pins. Nothing won't happen if you connect wrong one, except your problem still be there :D.

Alan
 

·
Registered
Joined
·
944 Posts
lol - im hoping this fixes it, was about to get rid of it with the repair costs ...... if this sorts it then I will clean and cherish it for a bit longer :eek:)
 

·
Registered
Joined
·
55 Posts
If not, and If you open it, check for plastic gear. You can purchase on ebay only gear and replace it. This is case if only gear is bad. But you are good wit resistor mode. I have both mods (EGR and swirl for 2 years now)
 
501 - 520 of 560 Posts
Top