Chrysler 300C & SRT8 Forums banner

521 - 540 of 561 Posts

·
Registered
Joined
·
944 Posts
Thnaks - appreciate the reply.

So will it actually run better with this resistor - assume with he flaps open all the time it will be more responsive ?
 

·
Registered
Joined
·
1,141 Posts
Discussion Starter #522
Resistors

Hi Guys,
I have the swirl motor failure symptoms on my 2007CRD. After reading all these threads I am going to try the resistor "trick" as being quoted a ridiculous price to fix the motor. I have one question - which pins in the plug do I put the resistor in - seems to be 2 answers reading this thread.

COULD SOMEONE CONFIRM THE PINS PLEASE

Thanks in advance :)
Use the two centre pins for swirl motor resistor and the two pins at the round end of the plug for EGR resistor.

I have been using the resistors since I started the thread about 5 years ago, currently on my Jeep for the last 2 years with no issues and emissions clean as a whistle.

Its pointless replacing the motor or EGR valve, the engine will not run any better and you still have the uncertainty of when it will fail again.
 

·
Registered
Joined
·
773 Posts
Use the two centre pins for swirl motor resistor and the two pins at the round end of the plug for EGR resistor.

I have been using the resistors since I started the thread about 5 years ago, currently on my Jeep for the last 2 years with no issues and emissions clean as a whistle.

Its pointless replacing the motor or EGR valve, the engine will not run any better and you still have the uncertainty of when it will fail again.
That's not 100% true. They tend to fail if the car is used for mostly short journeys or infrequently.

Mine had 13k on the clock when I bought it and the EGR valve went immediately [within the first week] followed shortly after by the swirl.

Since having them both done I've put 100k on it without trouble [from them anyway]
 

·
Registered
Joined
·
1,141 Posts
Discussion Starter #525
Thanks - getting resistor today - will report back.

Where is the egr plug - may do this as well whilst I am at it !
Egr is at the back of the engine on passenger side sat on top.
 

·
Registered
Joined
·
1,141 Posts
Discussion Starter #526
Here are a few pics of my homemade catch can mounted inside air filter housing.
 

Attachments

·
Registered
Joined
·
944 Posts
Ok got the fault codes now - here goes, assume one of these point to Swirl motor ?

P0234
P0046
V0106

That's all the stored codes.....

Also had to get a 5.7k resistor as Maplin had no 4.7k, assume this will be ok ?

Sound ok ?
 

·
Registered
Joined
·
944 Posts
Guys,
Need some HELP - fitted resistor and car has no lights but is really underpowered like I have no turbo. The following codes are "stored" from when my car lost power and the lightning bolt came on :

P0234
P0046
V0106

Do I have something else wrong - or do I have to reset something after fitting the resistor ?

HELP - thanks in advance.
 

·
Registered
Joined
·
3,655 Posts
From Service Manual:

P0234 = Turbocharger overboost condition
P0046 = Turbocharger boost control circuit performance

Can't find any reference to V0106, but in the Dodge DTC Manual, U0106 = Lost Comm with Glow Plug Ctrl Mod.
 

·
Registered
Joined
·
944 Posts
Take it it's not my swirl motor then more the turbo ? - if this is expensive my beloved 'C' will be getting traded in.

Any ideas anyone ? - only option ATM is dealers tomorrow
 

·
Registered
Joined
·
1,141 Posts
Discussion Starter #531
Turbo actuator

If the turbo was running ok and sounded ok before the limp mode it is possible the turbo actuator is faulty, this is the electronic box on top of the turbo and are a known failure item, it is the turbo equivalent of the swirl motor.

The dealer don't sell it as a seperate item but they are available refurb from a few suppliers on Ebay @ around a £100 it is a easy job to replace.

You can check if your own is working, get someone to switch ignition on and off and check if the linkage is moving, you can see it if you look at turbo from drivers side.
 
  • Like
Reactions: devilmaycare

·
Registered
Joined
·
944 Posts
Thanks mate - the actuator I can see moving up and down when I turn the key - assume this means it's ok and working ?. Turbo was fine until lightning bolt came on, and was even ok the day after for a while with no lightning bolt.

Really odd as I can hear the turbo whistle on revving - but no power when driving.

Is there a fuse or something in need to pull to reset something ?
 

·
Registered
Joined
·
3,655 Posts
P0234 = Turbocharger overboost condition
P0046 = Turbocharger boost control circuit performance

These DTCs would indicate that the turbo control is faulty. Just because you can hear the turbo and can see the actuator moving doesn't prove that everything is OK. My turbo appears to work normally, but I've never been aware of any "whistle". Sometimes a whistle can be the result of leaky plumbing.
 

·
Registered
Joined
·
944 Posts
ok - ECU / MIL light now on and fault still there. Cannot get a garage to look at it until Friday so I am without a car. I am close to trading this damn thing in - don't have time for dealers and independents with a 1-2 week waiting list to book it in.

Even tried Merc independents given its a Merc engine.
 

·
Registered
Joined
·
3,655 Posts
Have you considered the possibility of a faulty boost pressure sensor and/or associated wiring/connectors? I replaced an exhaust pressure sensor twice before discovering the problem was a dirty connector.

According to the Service Manual, DTCs can be triggered by plumbing leaks (which could explain the whistle) or by a blocked air filter.

I also noticed that the motor boost pressure servo has a link to the glowplug module; so perhaps the glowplug module DTC is significant. The boost pressure sensor is located near the glowplug module (see attached pic)
 

Attachments

·
Registered
Joined
·
944 Posts
Thanks for all the replies. Tonight I have checked the actuator on the turbo - moves on key cycle and when revving the engine so looks ok as far as I can tell. However when revving with my head under he bonnet there is definatly an odd sound / whistle / wind noise that's not normally there coming from somewhere.

Still waiting to get it in to a dealer - nobody else will help in my area. Still don't get how MIL can. E on and keydance on EVIC reports nothing.
 

Attachments

·
Registered
Joined
·
944 Posts
Well off to the dealers it goes this morning - been broken a week so had to resort to the expensive option. Removed resistor as I am sure they would frown at that and reconnected swirl motor. MIL light still lit and same as it was a week ago.

Time to sell a few kidneys for the bill :(
 

·
Registered
Joined
·
944 Posts
ok update from dealer. They are saying its the turbo actuator AND the swirl motor that caused limp mode and the MIL. They have cleared the codes, checked both the swirl and the accuator on the turbo and they test ok. They have also took it for a drive and cannot reproduce the fault / limp mode. Advise is take it away and drive it and if it happens again take it back.......... They are keeping it a few days to see if the fault returns.

Cost of new turbo = £4,500
Cost of Swirl Motor = £800

So - I don't think its the swirl as used resistor when it first broke so suspect that's the cause of that code - so it looks like the turbo actuator ......... How can I get this repaired at a reasonable price, can I take the "actuator off" and replace it myself ? ......

H E L P !!
 

·
Registered
Joined
·
3,655 Posts
If the swirl motor had been reporting a fault then this should have set the appropriate DTC. However, I wouldn't spend money on a new swirl motor if the resistor mod works.

If the fault is intermittent then it could be a chaffed wiring harness problem, so well worth double checking the wiring. I would still be a bit suspicious of the glowplug DTC, as the actuator takes its power via the glowplug module.

If you decide to go for a recon actuator then try this UK firm recommended by Riverracer in your other thread: http://www.300cforums.com/forums/crd-faults-error-codes/254714-help-please-power-loss.html#post2669474
 
521 - 540 of 561 Posts
Top