Chrysler 300C & SRT8 Forums banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
9 Posts
Discussion Starter #1
I had new injectors fitted to my 3,0 CRD a month ago, which fixed a hot start problem, and all was going well until today.

Now the flashing lightnong bolt is on and car feels like it has 60 horsepower, and accelerating from 30-50 takes nearly 30 seconds !

I had already read many threads on the swirl motor problem, so a few weeks ago I boiught a CRD Fuel Line/Hose Kit and CRD Swirl Emulator (plug) from the Custom 300 Shop.

I planned to get these fitted as a preventative measure (I just fitted an alternator shroud) but so much for forward planning... the failure has come up beore I got that far.

I am guessing fitting these should be easy, but does anyone have any tips or warnings, or things I should do at the same time (fuel filter?) ?

Thanks, Robbie
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #3
Thanks for the warning on the silicone fuel lines, which are the ones I bought.

I will return them, and just instal the swirl emulator for now.

I will fit new hoses of the proper type when I next change the fuel filter, no rush for that.

Thanks again, great forum !
 

·
Registered
Joined
·
30 Posts
Error code SWIRL AND EGR

Anyone here who can tell what the error code for malfunctioning SWIRL motor is??? and error code for EGR??
 

·
Registered
Joined
·
5 Posts
Hi sounds like we have same problems , so far the mech has changed egr valve ,glo plugs x 6 ,now they think swirl motor it's 2008 300c ...
I'm confused need advice of any
 

·
Registered
Joined
·
5 Posts
Hi there because it's desol I'm unable to receive codes but the mech first said it was glo plugs and replaced them ( it was never hard to start would start first time ) but lighting bolt returned then code was replace egr valve did. That all good drove car 20 kilometres first comes lighting bolt then check engine and it went in to limp mode ? Now the recon change swirl and that will fix problem so far it's cost $2300 au any advice
 

·
Registered
Joined
·
3,083 Posts
Best to check the wiring for damage in the engine bay first.

See picture. The wiring in the area of the yellow circle sometimes rubs through. Grab the whole wiring loom and twist around and check for wires that have rubbed through.

Other than the above it depends on what codes your man has noted. I assume you don't have that information.


Jack
 

Attachments

·
Registered
Joined
·
1,141 Posts
P1270 is swirl motor, just fit a resistor for 10p::smile::::smile::
 
1 - 14 of 14 Posts
Top