Chrysler 300C & SRT8 Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
First serious problem i've had so far. I was just driving my 300C around the block...turned right, then turned right one more time onto the main street, then I hit the gas and noticed a late response which I had never felt before. After I took my foot off the gas, the engine was still revving up. Of course I tried this a few times and I don't know much about cars but the first thing that came to mind was the tansmission. I was very upset becasue I only have 2000 miles. I drove it to the dealership I purchased it from, and there was nothing they could do becasue it was so late in the day. I made an appointment for the next morning, which was today. They have been nice to me everytime so far. I explained the problems i had been having and I also had the pulling to the right problem which I asked him to check out. He said its normal for this car to do that its not supposed to be straight...I laughed and said no its not normal I want you to fix it and he said ok. By now i'm not feeling so good about this...but I guess thats all I could do for now. So, now for the rental car...Enterprise comes and picks me up and under the chrysler warranty they will only let you rent a chrysler thats no more than 40$ per day. I also had a problem because Im 21 years old and he said I am only aloud certain cars becasue of my age. He tried to give me a mini van and I said f*** that I dont think so. I wished I never left the dealership becasue I would have given them an earfull, which I will do tomorrow about that. I ended up with a v6 dodge magnum which was one of the worst cars I have ever driven in my lifetime. I received a call from the service department in the late afternoon. He says "we cant find anything wrong with your transmission"...It is however, low on transmission fluid and we looked for leaks but couldnt find any. He said he fixed the alignment problem also...I can't wait to check it out tomorrow morning. We'll see how it goes...
 

·
Premium Member
Joined
·
829 Posts
I see you're in OC - care to tell us who the dealer is?
 

·
Administrator
Joined
·
3,667 Posts
This isn't sounding toogood tooshort... Be sure to update us!
 

·
Administrator
Joined
·
3,667 Posts
tooshort, lotsa dealers lurk on this site. Since your post is uniquely descriptive, it may be best if you PM the dealer info at this point... just to be safe. You don't need to add some sort of retaliation to your list of problems and you never know :rolleyes:
 

·
Registered
Joined
·
1 Posts
transmission problem?

I just turned over 700 miles on my C yesterday when it started making a groaning noise and vibration about 40 mph. It sounded like a worn out disk brake grinding. It is ok at idle and thru the first 3 gears and coasting is smooth as glass but trying to accellerate from 30-40 mph it sounds like a dying elephant.
Any ideas.
The dealer drove it and heard the noise but had no ideas yesterday.
I don't see what it could be but the tranny
:(
 

·
Registered
Joined
·
124 Posts
I never had any problems renting a car. I've been renting them since I was 21.

Now, I had a '59 Cadillac that would behave like you are describing, and that was ALWAYS because it was low on transmission fluid. It had a leaky seal. Dumping some Dexron III into it would fix 'er right up.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
I got my car back today...They said that it actualy wasn't low on tranny fluid like he said to me yesterday and he said they read it by pressure and if it is off at all even by a drop it would read low...I don't know too much about that but common sense tells me thats a bit odd. Anywyas we went for a drive and I drove it pretty hard to test it out...Seemed like it had a little more power than the other day but maybe thats from driving that damn magnum around for a day. I've been driving around all day and it seems ok but I swear it still feels like theres less power at times when I had more before...does anyone know why that may be? And I would rather not name the dealer they have been very nice to me and I wasn't trying to make them look bad becasue to my knowledge they did nothing wrong so far...The main problem I had yesterday was with the damn rental and I don't know the laws in NY but in california you have to be 25 to rent a car...The only reason I was even aloud to rent a car was becasue it is a part of the agreement with chrysler.
 

·
Registered
Joined
·
82 Posts
I thought the magnum was a close cousin to this car?? What was so different about that car that it was the worst in your life?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
190 hp...If I floored it for like 10 seconds I would almost be at 60 mph...no joke...its a v6 and it was the lowest model they make...there is a v8 magnum with a hemi and im sure thats better but I swear it felt like I was hauling a motorhome with the magnum all day...
 

·
Registered
Joined
·
323 Posts
Are you using the auto-stick or automatic during your driving. This car adapts to your driving style and will change shift points depending on it. When you first start the car in the morning, drive it aggressively from the get go. You will notice more power the more aggressive you are with it. It is a huge difference between when the computer is in most aggressive mode versus being more laid back. This may explain why you feel the power on certain days versus others...just a thought.
 

·
Registered
Joined
·
381 Posts
What's the big deal as to what kind of rental they give you. You should be happy with the fact that you get one without being charged for it.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
jcsganga34, thats a good Idea I will try that out tomorrow being really aggressive when I start her up. And about the rental...i'm picky, I'm used to driving a v8 with power and I get a piece of crap car. I only had 2000 miles on my car and I had to take it in I was very disappointed and I thought they were supposed to get me something comperable to my car. I paid 40 grand for my 300c and the rental I got is worth about 20 grand...not too fair of a trade off if you ask me...
 

·
Registered
Joined
·
265 Posts
Hey... For my rental at the 6K maint and checkup for a few things... I got a Stratus SXT... crappy ride with a 4 cyl... I wasn't real impressed with how Enterprise was involved, but whatever, I put it on the comment card I sent back.

That car sucked and I was happy to get mine back. I expect the dealer to want you to take some of their other cars out because you may want to buy them... But a 300C owner cross shopping a stratus? Hmm, no.

BTW, I had no problems with age, I am now 24 but have also been renting them since I was 21 and even the week after I turned 21 and went to Vegas, I got a convertible for $30 a day and loved it. =)
 

·
Registered
Joined
·
19 Posts
dragnut said:
I just turned over 700 miles on my C yesterday when it started making a groaning noise and vibration about 40 mph. It sounded like a worn out disk brake grinding. It is ok at idle and thru the first 3 gears and coasting is smooth as glass but trying to accellerate from 30-40 mph it sounds like a dying elephant.
Any ideas.
The dealer drove it and heard the noise but had no ideas yesterday.
I don't see what it could be but the tranny
:(
This may be a new serious new problem. My new 300C with 290 miles on it developed a low RPM vibration and groan (only way to explain it) when between 1500 and 2000 rpm. At first is seems like road noise until it groans. Any time the engine idles down and you start to accelerate again I feel and hear the vibration, i.e. even on the freeway doing 65 if you take you foot off the gas and let the RPM drop. I can put my foot in it and it shifts great, I just can’t cruise. I’ve had it in the dealer for 5 days and they are scratching their heads and think it is a torque converter problem. I called an acquaintance that is a second-generation Chrysler Transmission specialist he just happens to be working on his dealerships general manager’s 300C that has the exact same problem as mine. He thought he had it fixed last week but it is doing the same thing again. He has sent a tech email into the Chrysler to see what’s up. I’m seriously upset that this may be a major flaw in recently produced 300C’s :(
 

·
Registered
Joined
·
19 Posts
Received my C back today. Per the Service Manager the issue was caused because the A/C condenser is right over the Transmission and condensation runs down on the trans settling near the opening where the fill tube enters the transmission and moisture seeps into the trans. I quote him “this has happened to three 300 C’s that they know of “. They flushed the transmission fluid out 3 times to make sure all the water was out. As he was explaining to me the resolve I keep looking for the hidden camera and/or waiting for him to say “B.S. I got ya”. But he stuck with his story, I drove the car out of the dealership and it drives like a dream. We’ll see. Still waiting to hear the resolve from the Chrysler tranny expert working on his general managers 300C.
 

·
Registered
Joined
·
1,048 Posts
LoanWizard said:
the issue was caused because the A/C condenser is right over the Transmission and condensation runs down on the trans settling near the opening where the fill tube enters the transmission and moisture seeps into the trans. I quote him “this has happened to three 300 C’s that they know of “. .
THIS also happened to me..I got NEW tranny
 

·
Registered
Joined
·
375 Posts
I saw a little "wet spot" under my ride last Friday and knew it wasn't the a/c condensor, because it had been sitting for a day....I pulled it out, and yep...trans fluid.

TSB for the O-rings was the problem.

I had a 4 door HEMI Dodge Ram pickup all weekend, and pickup her up Monday.
Enterpise will always negotiate with you, and you get up to $40 per day - you won't get a 300C, but the HEMI Ram truck was fun for a few days.
 

·
Registered
Joined
·
18 Posts
FYI:
I too, noticed transmission fluid on the floor everywhere the Hemi was. There is no way for us 300 owners to check the level of transmission fluid....I just hope Chrysler engineers are reading this, because this is a serious problem for all of us...
 

·
Registered
Joined
·
160 Posts
CDBLU said:
FYI:
I too, noticed transmission fluid on the floor everywhere the Hemi was. There is no way for us 300 owners to check the level of transmission fluid....I just hope Chrysler engineers are reading this, because this is a serious problem for all of us...
just noticed that my 450 mile old 300c is leaking tranny fluid as well. quite a bit actually. so is there a faulty seal issue?
 
1 - 20 of 21 Posts
Top