Chrysler 300C & SRT8 Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2006, Chrysler, 300C, 3 litre diesel, Automatic, Engine will crank but no fire/ start Have reset ecu, have tried different keys, no change just wont start.
Security light is going off with the other dash lights during start up.
It has a glow plug fault when put on diagnostic system, other wise vehicle has been just great. There has been no signs of any trouble till today.
If you have any ideas so I can get it started to take into a repairer I'd be very grateful. I live a hours drive from any sort of town.
 

·
Registered
Joined
·
52 Posts
Heaven has no rage, like love to hatred turned...

And I do hate my CRD, but I need it to run again so I can sell it.
I have the same problem with the same symptoms,
Did the crank angle sensor work??

Cheers
Steve
 

·
Registered
Joined
·
52 Posts
Yesterday I hated my CRD...... a bottle of bourbon later, I'm not sure how i feel...
In the last 12 months:
1: had to pay the stealership almost $500 for a new key
2: park brake lockout failed (stealership wanted $30 for parts and $300+ to fit) bought the aluminium one from Billets and fitted myself.
3: turbo actuator failed (stealership wanted around $3,000 for it and the turbo) took it out, sent it to the UK, repaired and sent back total cost $460 (inc postage)
4: currently the alternator has failed (stealership wants $1,660 not including fitting) can buy one on ebay for $550 but will take it out today and give it to an auto elec.
5: now it seems the crankshaft sensor has failed, apparently didn't like sitting for 2 weeks.

Not to mention the on going problem with tyre sensors (stealership want anything from $150 to $210 depending on the day) the auto trans feels like it's slipping if you really put the boot in,
the headlights don't drop when a car is coming the other way, they raise and lower when ever they feel like it.

And then I look at the TSB list, and think f#ck what's next :(
 

·
Registered
Joined
·
2,416 Posts
Yesterday I hated my CRD...... a bottle of bourbon later, I'm not sure how i feel...
In the last 12 months:
1: had to pay the stealership almost $500 for a new key
2: park brake lockout failed (stealership wanted $30 for parts and $300+ to fit) bought the aluminium one from Billets and fitted myself.
3: turbo actuator failed (stealership wanted around $3,000 for it and the turbo) took it out, sent it to the UK, repaired and sent back total cost $460 (inc postage)
4: currently the alternator has failed (stealership wants $1,660 not including fitting) can buy one on ebay for $550 but will take it out today and give it to an auto elec.
5: now it seems the crankshaft sensor has failed, apparently didn't like sitting for 2 weeks.

Not to mention the on going problem with tyre sensors (stealership want anything from $150 to $210 depending on the day) the auto trans feels like it's slipping if you really put the boot in,
the headlights don't drop when a car is coming the other way, they raise and lower when ever they feel like it.

And then I look at the TSB list, and think f#ck what's next :(

Yep, Can understand how you "Hate your CRD". That's a nightmare.
Appears as though you get ripped off the same as the UK customers.

Seems as though it still needs a bit of work, from your description.

Good Luck Mate.

At least its a "Not sure now" Keep taking the medicine.

Jack
 

·
Registered
Joined
·
37 Posts
Mine does the non starting thing from time to time. Just crank it continuously and it starts after exactly 30 seconds. Prob not good for the starter but it seems to work for me.
 
1 - 8 of 8 Posts
Top