Chrysler 300C & SRT8 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I bought my 2013 in Dec, 2013. Since then, the Uconnect has failed to detect my iPhone 5 at least seven times. My iPhone will work fine with my other Bluetooth devices at the same time that the Uconnect won't see it. If I delete my iPhone and attempt to re-pair it, it will not detect the phone at all. I tried this with a friend's phone, and had the identical problem. But, while the Uconnect won't work, we can both pair the phones in her Ford. After several hours (or days?) it will work again. My old Chevy never had this problem. I don't know if it's a loose connector, bad software or something else, but it's the Chrysler, not the iPhone. If I bring it to the dealer, it (of course) will be having one of it's "good" spells, and they won't see any problem.
 

·
Registered
Joined
·
418 Posts
Have you brought it to the dealer? Or are you assuming they won't see the issue....

But the uconnect on these can be a bit fickle at times. I've had to turn the car off and restart it to get it to pick up my music.. On both my last 300 and my new one... But what you're describing is more then that... Take it in and have it checked out....
 

·
Registered
Joined
·
3,692 Posts
It matters that you go to the dealer, whether they see the problem or not. We know Uconnect has its problems and Chrysler basically has chosen to bury their heads in the sand and wait it out.

The more trouble reports on the system, the better. In addition, you should open a ticket with Uconnect and ask them to escalate the problem.

If you still don't get satisfaction, then I suggest opening an executive escalation.

I would not avoid the dealer regardless of their reaction, because at least you document the problem and you have more ammo the next time it happens.
 

·
Premium Member
Joined
·
108 Posts
Will it pair with any other phones. You can always delete them from the U Connect after you pair them. Or any other blue tooth device this may help determine where the problem is...
 
1 - 4 of 4 Posts
Top