Chrysler 300C & SRT8 Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have a 2012 Chrysler 300c and on my way to work I noticed my phone wasn't charging or being read on my uconnect. The light on my USB port is on but as soon as I plug in my iPhone charger, the light goes off and it won't charge my phone (my charger works fine). The only thing that works fine is the Aux. Did you have the same problem?
 

·
Registered
Joined
·
125 Posts
I believe the part# you will need for replacement is: 68068290AD
 

·
Premium Member
Joined
·
7,946 Posts
have you ever had it work the way you want? I was under the impression that the USB was one way only for uploading music onto the internal disc, and that other standard usb functions werent enabled. Maybe I'm just thinking about earlier versions
 

·
Registered
Joined
·
125 Posts
I know that on the 2011 and up models, the USB port can also be used for charging.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Yes everything worked perfect, my music playlist would show up. Now It won't even charge my iPhone. The only thing that's working fine is the AUX. The light is on but as soon as I plug in the the wirx, it turns off.
 

·
Registered
Joined
·
18 Posts
I recently purchased a 2012 limited and having the same issue, no charge and it won't import or recognize the iPhone. Aux works fine.
Probably buy the replacment harness per JMitch's recommendation.
 

·
Registered
Joined
·
1 Posts
nope it isn’t your cable and.no stuff doesn’t just break for no reason when you buy it for 38,000.... it’s a piece of crap. Mine is busted too and I just bought it. Get in there and have them fix it ASAP before they tell you that’s not included in your warranty. One port lights up the other is totally dead , didn’t use it so I didn’t break it, it’s another Chrysler special... rip off nonsense
 

·
Premium Member
Joined
·
1,346 Posts
Allen, I don't have a solution. My wife just happens to have an S9+, but I traded my 2012 for a 2020. The radio in my 2020 is so very different from your 2013, I would not expect any experimentation with my wife's phone to help. :cry:

I thought of a couple more things you could try. Does the USB port charge your S9? If not, the USB port may have died. Do you have another phone with which to experiment?
 
1 - 17 of 17 Posts
Top