Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
668 Posts
Discussion Starter #1
I have found this trouble code using my Diablo:

variable resonance induction system solenoid #1 circuit

I have installed Volant CAI at the dealer workshop over 3 months ago, I don't really have any issues with the CAI or the Car but I was worried when I got this error !!!

Any idea how to solve this problem (If it was really a problem) ? btw the error code is "P1521" which is the "Wrong Oil" Error but the description is as I've written above :dead1:
 

·
Premium Member
Joined
·
4,708 Posts
First, are you using the correct weight oil?
Second, I was once warned by a service writer that the computer was complaining about the wrong oil. I kinda laughed at him as nothing but 5W20 had ever been put in my engine. To my knowledge (and there were PLENTY of opportunities for the stealership to check!) they have never seen it reoccur. Clear the code and/or drive it normally to see if the CEL goes away.
Other than that, by adding 2 and 2 (induction system solenoid and wrong oil), I'd venture a quess that there is something amiss with the #1 solenoid, and/or its circuit in the MDS system. That may not be the solenoid/circuit associated with the #1 cylinder (if there even is one on the #1 cylinder). The MDS solenoid control wires issue from the PCM (located in the area beneath the cabin air filter in the engine compartment). Take a look to see that all appears to be in order between the PCM and each solenoid.
 

·
Registered
Joined
·
668 Posts
Discussion Starter #3
The MDS solenoid control wires issue from the PCM (located in the area beneath the cabin air filter in the engine compartment). Take a look to see that all appears to be in order between the PCM and each solenoid.
I don't really know what Oil does the Stealership :)biggrin:) use but I'll ask them first thing tomorrow morning. I will try to check beneath the CAI myself to see if everything is alright, and you know something after applying the Diablo I can hear a cranking noise coming from the left side of the car ... so it might be actually because of this issue as well ... who knows :dead1:

Will keep you updated :biggrin:
 

·
Registered
Joined
·
31 Posts
Hey Spider, there is a TSB dated March 15 2008 for this DTC (P1521) in which the repair is a PCM flash update. I would suggest having this done first and then verifying that the correct 5W20 is used.

Mike
 

·
Premium Member
Joined
·
4,708 Posts
I don't really know what Oil does the Stealership :)biggrin:) use but I'll ask them first thing tomorrow morning. I will try to check beneath the CAI myself to see if everything is alright, and you know something after applying the Diablo I can hear a cranking noise coming from the left side of the car ... so it might be actually because of this issue as well ... who knows :dead1:

Will keep you updated :biggrin:
The stealership should ought to know what weight oil is required. Whether they actually supplied it is certainly questionable, especially in your part of the world where they may not have a variety of oil weights on hand, despite plenty of crude underfoot!
The PCM is located beneath the cabin air filter, not the CAI. The cabin air filter is located in the engine compartment, passenger side, beneath a mesh plastic grill just forward of the windshield. The PCM is next to it, a kind of thin metal box with a bunch of wires connected to it. Four of those wires head off to the MDS solenoids. If you removed the engine cover to do the CAI installation you may have pulled on something that you shouldn't have pulled on, thus disconnecting something. The on-board diagnostics (OBD) periodically runs a functionality check and may have found an open circuit to a solenoid, which popped the DTC.
It also may have been an single hiccup of the electronics and all will return to normal after 4 or 5 normal engine runs.
 

·
Premium Member
Joined
·
4,708 Posts
I don't really know what Oil does the Stealership :)biggrin:) use but I'll ask them first thing tomorrow morning. I will try to check beneath the CAI myself to see if everything is alright, and you know something after applying the Diablo I can hear a cranking noise coming from the left side of the car ... so it might be actually because of this issue as well ... who knows :dead1:

Will keep you updated :biggrin:
Before you have the stealership see the car install the stock tune back into the car from the Diablo to avoid any "issues"!
 

·
Registered
Joined
·
435 Posts
thanks for the vocab lesson, "stealership" luv it!
 

·
Registered
Joined
·
668 Posts
Discussion Starter #8
Thanks ...

Before you have the stealership see the car install the stock tune back into the car from the Diablo to avoid any "issues"!
Thanks for all the information bro :fing02: I really appreciate your support.

I have installed the stock tune as soon as I heard the noise I told you about ... I'm planning to upgrade the diablo before re-installing any custom tunes.
 
1 - 8 of 8 Posts
Top