Chrysler 300C & SRT8 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hey all, I bought a 2005 300c used form the dealer with 8k on it and when I bought it it had all the features plus options I wanted on it, including the sound system. Until today I noticed I don't have a center channel speaker, and no rear deck sub. The option lists says the car has the 368watt amplifier. SO do I even have boston acoustics speakers or are they the chrysler brand. And is there any way of upgrading to the ba speakers now? The car has a ton of bass coming from the front doors but very little from the back.
 

·
Registered
Joined
·
214 Posts
Sounds like you have the 6 speaker set up....

Taken from the Audio FAQ:
http://www.300cforums.com/forums/showthread.php?t=5298

Speaker Questions & Info:

Standard 4 Speaker Package:
- 2 6x9 Inch diameter speakers in front doors.
- 2 6x9 Inch diameter speakers in rear shelf.

Boston 6 Speaker Package:
- 2 3.5 Inch speakers on the top of the dash.
- 2 6x9 Inch diameter speakers in front doors.
- 2 6x9 Inch diameter speakers in rear deck.
- 1 288 watt amplifier in front dash directly behind headlight switch.

Boston 8 Speaker Package:
- 3 3.5 Inch speakers on the top of the dash
- 2 6x9 Inch diameter speakers in front doors.
- 2 6x9 Inch diameter speakers in rear deck.
- 1 7" Subwoofer mounted on rear deck.
- 1 380 watt amplifier in front dash directly behind headlight switch.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
djjasond said:
Sounds like you have the 6 speaker set up....

Taken from the Audio FAQ:
http://www.300cforums.com/forums/showthread.php?t=5298

The only thing thatbugs me is that I got a option sheet printed out for my car that states every last option / feature by code. and in it it has the code and labels it as 368watt amplifier. the code is RDFP. The 6 speaker boston setup should have the 288watt amp not 368 right?
Why does mine have the 368 or so it says?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
One other quick question, do I have the same boston acoustic speakers as in the sg2 pkg? besides the subwoofer the speakers are all the same right?
 

·
Registered
Joined
·
214 Posts
Hersheys C-

If you're coming at this from the perspective of whether you paid for something that you didn't get, I'm not sure what to tell you. Without being able to physically look at your car, it's difficult to tell if something was there but removed or if in fact it was never there, etc.

If your perspective is to recreate the SGII package by adding the factory subwoofer, I think most on this site would tell you to upgrade before going down that path. The "boston" speakers in this car are hardly what you would get from an aftermarket boston speaker (if you were attracted by the Boston name). Look at the Audio FAQ (link in previous msg) to see a picture of these fine paper products.

This "could" and I don't know for sure - just speculating... could be a situation where the automaker uses the same amp in the 6 and 8 speaker set ups to get economies of scale when ordering from the supplier. The difference in the six speaker system power rating may not be the amp itself being different but instead the watts you get without the subwoofer and center channel installed. I say this because I have read on this forum that members without the subwoofer often have the wiring for it. If you were really curious, you could post in the buy sell column and probably get a factory sub for cheap.

I have SGII but I am in process of replacing the fronts, rears, subwoofer, and amps in my car. I found the factory set up really annoying as you suggest (bass in the door, not enough mids up front, etc). I also found them to be 368 highly exaggerated watts.
 

·
Registered
Joined
·
32 Posts
djjasond said:
Sounds like you have the 6 speaker set up....

I have the same setup! Only after seeing this post did I check the center "speaker"! I always thought it was weird setup with 3 dash, 2 doors and 1 back, but guess again.
 

·
Registered
Joined
·
443 Posts
if you do have the BA7 -which was available in 2005--- the sub should be right between the rear deck 6x9's. the center speaker should also work......which does nothing but destroy any front imaging in my opinion. The easiest way to find out is look in the trunk for the center mounted sub. if it's there you've got the BA7 and your center channel will work....although you probably won't want it to when you hear how much better it sounds without it. if there's no sub.....then you've got BA6......2 dash, 2 front doors and two rear decks. hope this helps
 

·
Registered
Joined
·
214 Posts
I'm confident that if lightning hit your car, 368 watts would be dissipated acorss the speaker voice coils - for about 10 femtoseconds.
You're killin me dude. That was some funny sh%t right there.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #11 ·
Well today I checked to see if I had a sub, and lo and behold there it was. Sounds like crap thou. Becasue I coul;d not even tell that it was working until I touched it. And I do have a center channel and its working too. but I don't have the boston acoustics label on the mirror sails, which is why I posted this topic to begin with. Like someone said earlier if you have the ba7 then the car should have the ba badges on the mirror sails and mine didn't. But all is good, but definitly gona have to do something about that sub! Wonder why my car doesn't have the badges?
 
1 - 11 of 11 Posts
Top