Chrysler 300C & SRT8 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
Any of you guys experienced this? I havent done and performance mods, it happpens when i gently accelerate. If i get on it, it goes away...
 

·
Registered
Joined
·
26 Posts
Yeah, I have it on my '05 300C. Sounds like it's originating from the exhaust. Doesn't happen that often for me though.
 

·
Registered
Joined
·
23 Posts
stupid as it may sound my sister had the same problem with her audi... well wasnt a problem but she just didnt know it was a turbo... being a badge buyer she never even looked at what engine it had,
Id check the condition of drive belts as when they are wearing out they can make a whistle/spooling noise, dont lube the belts, makes it worse
 

·
Premium Member
Joined
·
1,788 Posts
I don't experience it on my 300, but on my way to work almost everyday there's this old Toyota Previa van (the one that looks like an egg) commuting the same way I do, and it WHISTLES! Seriously! The tail pipe on it must have a British police whistle stuck in it. You can't hear the engine or anything from the van. Only the whistling sound. It's actually a kick. People smile when it drives by. It's like a cartoon the way it looks and sounds.
 

·
Registered
Joined
·
26 Posts
Come to think of it, mine's more of a whirring than a whistle. I used to drive a Saab Viggen and the turbo would definitely whistle. It doesn't sound anything like what I occasionally have on my 300C.
 

·
Premium Member
Joined
·
4,455 Posts
Mine has a bit of a quiet wheeeee noise that goes with the exhaust, I always just figured it was the intake.
 

·
Registered
Joined
·
23 Posts
have the same problem look like it'e the air intake before putting the cai it was less and with the cai it improve the noise !!!!!!
 
1 - 10 of 10 Posts
Top