Chrysler 300C & SRT8 Forums banner
1 - 20 of 50 Posts

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #1 ·
I got the 3.61 sw flash a few months ago which seemed to correct the occasional sweep of the wipers when signaling. Today the wipers were more active than they have ever been sometimes sweeping when the signal cancelled by turning the wheel. The simple fix is to leave the wipers in the off position and put them on rain sense only when it rains.
 

·
Registered
Joined
·
170 Posts
I've been experiencing this too... but it is only a minor nuscane.

I don't think a flash fixes this... I think I "push" the stalk in when I signal. :)
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #3 ·
No, if you pushed the stalk your washer would activate I initially entertained this thought. I switched mine to off, prob solved
 

·
Registered
Joined
·
332 Posts
AHHHH QUICK QUESTION,

Sorry might be offtopic but quick question, how do u set the wipers in rain sense mode.
 

·
Registered
Joined
·
124 Posts
I believe any position in the "delay" area of the stalk is actually rain-sensing...it adjusts the sensitivity.

My car was built ages ago: March, 2004. I occasionally had the turn signal wiping problem. I just got flashed with the most recent software, and now it sweeps very frequently. We'll just have to wait for yet another flash to fix it.
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #7 ·
CT is correct, anywhere in the delay mode is rainsense as long as it is turned on in the EVIC personal settings.
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #9 ·
Mine works fine, if I continue to click it wipes faster in rain sense mode, if it rains harder the wipers sweep faster or if I drive on the freeway vs the street.
 

·
Registered
Joined
·
6 Posts
I took my 300C in for an oil change and asked them to check the wiper issue with the turn signal, and of course it couldn't be duplicated at the time. Now a month later it is worse and the dealer could duplicate it, but they did not know how to fix it and said they were consulting Chrysler.

Has anyone had a dealer fix this problem?

Thanks.
 

·
Registered
Joined
·
61 Posts
It does

cmego said:
Position does not appear to change sensitivity. Nor does rain.
IMHO it changes the sensitivity of when to turn on. I noticed this when I start my car in the fog or driving through the fog. At highest sensitivity the wipers will turn on once I turn on the car in the morning. At lowest sensitiity the wipers stay off till I start driving through the fog.
 

·
Registered
Joined
·
6 Posts
Just FYI- My problem was fixed today- we'll see. The dealer replaced the turn signal/ wiper stem on the colum with a new one. Hopefully I won't have to resort to the band-aid approach by disabling the rain sense-ing wipers except when I need them.
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #13 ·
That's an odd solution, a mechanical fix for an electrical problem. Call me a skeptic but I doubt the problem is the stalk, I hope it works, I' ll get mine done.
 

·
Registered
Joined
·
23 Posts
I have had this problem since the get-go. DC claims "it must be how I turn on the turn signals". BS. I do NOT agree that the "fix" is to turn off the automatic mode and only turn wipers on when you need them this auto mode is a FEATURE of the vehicle. For it to not work properly it a FAULT of the vehicle. Personally I am convinced that the problem lies in the turn signal switch stem OR we have a short somewhere. I can have sheets of water on the windshield and the auto feature doesn't work but, yet again, I can be driving in total sunshine and "Christine" decides to do a few sweeps of the wiper.

Please note that I am a jaundiced customer (that would dearly love to love this car) as I also have headlights on in broad daylight (no day time running lights on this car!), the automatic temp. setting heater cooks me randomly, the clock in the radio has been known to change time on its own, seat does not always adjust itself to my personal settings........ not to mention that I have gone through two sets of tires in 14K and have filed lemon law!
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #15 ·
C1, you sound like my brother with his caravan and sticking brakes that have worn out 2 sets of pads in 6,000 miles!, I told him to look into the PA lemon law, it's a shame the build quality is so far below Acura, fortunately my C has only had a few glitches but glitches nonetheless, I plan to keep it 6-7 years and love it.
 

·
Registered
Joined
·
21 Posts
My wipers started misbehaving about a month ago (approx. 5500 mi.). First only when i flipped turn signal. then more often. now sometimes even when no turn signal is on. all on sunny days. It's becoming a little more irritating, but I'm hesitant to get my software flash upgraded because i fear it would be the begininng of chronic electrical problems. hey, maybe it will "just go away." yeah right, like the lines on my face.
 

·
Registered
Joined
·
6 Posts
stem switch fix?

So many of the postings about the phantom wiper sweeps (this thread and others) conclude that changing the software up to 3.61 will fix the problem. I have found that my blades come on more often (for no reason) now that the EVIC has been flashed to 3.61. The service writer told me it's a stem switch problem. Who out there has found that replacing the wiper control stem (and associated switches) fixed this problem? Perhaps it is a combination of the flash and the switch that fixes the issue? Luckily (?!) I live in Arizona and we are moving on to summer soon so I will not have to contend with rain for a few months. Switching the wipers from "automatic" to "off" is a quick solution although it feels like letting the problem win.

Well, if the stem switch replacement really fixes the problem, let me know; otherwise, I won't waste the time taking the 'C into the dealer.
 

·
Registered
Joined
·
31 Posts
I also had the phantom windshield wipers coming on. Back in January I had my car in for service (the recall) and mentioned that to them. They upgraded the software and installed a new turn signal switch. So far that seems to have cured the problem. It worked for me!
 

·
Registered
Joined
·
16 Posts
Not only have I noticed the wipers sweeping when I use the turn signal on non rainy days (this began around 10k miles), but last week when it was raining cats and dogs it stopped sweeping with the turn signal on. :confused: I think this is becoming a major issue. Took to my dealer and "they can't duplicate it." I will show them my self when I go get the car. Anyone else having the same issue, i.e. not sweeping?
 

·
Registered
Joined
·
2,719 Posts
Discussion Starter · #20 ·
Mine has mysteriously stopped, I forgot I even had the wipers on until it rained and they swept normally, have not swept with the turn signal for 6 weeks or more.
 
1 - 20 of 50 Posts
Top