Chrysler 300C & SRT8 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
770 Posts
Discussion Starter #1
Hey what is it with these windshield wiper controls. I know that I should read the manual but... How many settings are there. It seems like 10 or so. The first setting seems to be automatic but it has a mind of its own. To get to where it is just a normal low or slow setting with out pauses is like setting 8.

Bob
 

·
Registered
Joined
·
208 Posts
There is a small rain sensor located below the rear view mirror which will tell the wiper when the windshield needs to be cleaned. The different settings control the sensitivity of the sensor, which will cause it to work more often, but only if it senses rain. One thing to remember is to shut the wiper switch off after it stops raining. I forgot once and two days later went to clean the window at a gas station causing the wipers to start when I wet it down!
 

·
Registered
Joined
·
563 Posts
Anyone notice when the rain sensing wipers are on and it's not raining, that when you use the right turn signal the wipers will make one pass? Is this a software issue or a wire problem. Doesn't happen if you turn the wipers to off.
 

·
Registered
Joined
·
441 Posts
BBHemi: this thread had a similar comment when hitting the LEFT signal: http://www.300cforums.com/showthread.php?t=1534&highlight=wipers

rdmac: I was a little annoyed by the sensing wipers at first, but I got used to it. I prefer to keep the wipers on the slow side, the first notch, but I still feel they come on too fast too soon in light rain. My EVIC shows the 2/28/04 firmware. You can shut off the sensing function in the user settings menu.
 

·
Registered
Joined
·
588 Posts
Had that same problem, but only with the left turn signal. The last upgrade to the EVIC, dated July 27, 2004, was just to fix that among other things and it did, at least here.

Did you have that upgrade installed? If not, you should.

If you did, you may have uncovered another glitch because the wiper switch should be able to be left on at all times, given that one understands that the wipers will function anytime the windshield gets wet.

For example, in addition to what has already been mentioned, one must be sure to turn it off before going into an automatic car wash.
 

·
Registered
Joined
·
887 Posts
I have the issue and it does not seem to be right/left sensitive. I only notice it when it's not raining and the windshield is dry, and it happens prob 2x/day. I read some issues with the software fix install, and don't know if I feel confident with the dealer, so I'm a little hesitant to take it in.
 

·
BLOODY ADMENSTRUATOR
Joined
·
12,606 Posts
Definitely get the latest software upgrade. It "fixes" and improves a number of issues, including the wiper problem. There is no charge for this warranty procedure. Your car will love you for the "brain massage".:)
 

·
Registered
Joined
·
563 Posts
Thanks for the feedback. Hesitant to take it in and get upgraded. Read a few posts where folks had dealers erase flash memory then have problems downloading and required to get new parts in already flashed. I read that here or on dodgemagnum.net. I think I will live with it for now.
 

·
Registered
Joined
·
887 Posts
BrilliantBlack,

I was thinking that too, but talked with my service guy today about it. He did acknowledge it could happen (the connection getting "interrupted" during the reflash), but said it was very uncommon. I'm now having the flash done next week.
 

·
Registered
Joined
·
588 Posts
I took mine to a little ol' county 5* dealer who didn't even know that he had the upgrade in stock. I had to come back a couple of days later once he had it loaded into the StarTech computer they use to diagnose/flash these cars. It was done correctly but took almost 3 hours, which IMO, is asinine.

My reasoning was that since the car is under warranty; someone will get it done and it needed it for reasons mentioned earlier.

Suggest you get your unit flashed ASAP.
 

·
Registered
Joined
·
477 Posts
mileshoover said:
I took mine to a little ol' county 5* dealer who didn't even know that he had the upgrade in stock. I had to come back a couple of days later once he had it loaded into the StarTech computer they use to diagnose/flash these cars. It was done correctly but took almost 3 hours, which IMO, is asinine.

My reasoning was that since the car is under warranty; someone will get it done and it needed it for reasons mentioned earlier.

Suggest you get your unit flashed ASAP.
yeah i'm going in next tuesday. my present flash is february something.
 

·
Registered
Joined
·
196 Posts
I do not know how old your cars are, but mine was just delivered a little over a week or so ago. It has rained/snowed all but 2 of those days. My wipers seem to work fine. I am assuming I have the latest software version. How do I check? A couple of times I have bumped the wiper stalk too hard when trying to turn on my right turn signal and activated the "mist" button on the wiper stalk causing the wipers to cycle once. Could this be happening to any of you experiencing the problems?

I have really enjoyed my rain sensing feature. It takes a while to figure out what works best in what situation. It was pretty cool being able to leave the wipers in a single position and forgeting about. I was on a business trip and drove 185 miles on Interstate 35. It rained on and off the whole way, I passed trucks during heavy downpours and during light mist. I didn't have to touch the wipers, they adjusted in perfect time.

When I got back in town I took it to the nearby full service car wash and forgot and left on the automatic wipers. They were off until it was moved into the pre wash. Shure enough the wipers came on. I could only sit there and pray that the hanging strips of cloth that rotate back and forth in the car wash would not snag on my wipers and rip one off. Luckily nothing happened.

Good luck and have a great Thanksgiving. I know I am thankful for something that's parked in my garage.
 

·
Registered
Joined
·
218 Posts
how do..

u get the headlight washers to work. is it just when u do the winshield wipers or is there a special button, cause they didn't work w/ the windshield button. and i looked in the manual and found nothing, wierd
 

·
Registered
Joined
·
731 Posts
I read something in the manual. I beleive it was an addendum. They will work if you have your headlights on and you use the windshield washer. I believe they will only work the second or third time pressing the windshield washer.
 

·
Registered
Joined
·
101 Posts
The headlight washers will automatically run every other time you use your windshield washers, and I sure wish they didn't. I frankly wish you could have ordered HID without this option, it just detracts from the front of the car. Oh well. Anyone know if they are removable? (Sorry to hijack the thread)

-Chris
 

·
Registered
Joined
·
477 Posts
Black Hemi said:
The headlight washers will automatically run every other time you use your windshield washers, and I sure wish they didn't. I frankly wish you could have ordered HID without this option, it just detracts from the front of the car. Oh well. Anyone know if they are removable? (Sorry to hijack the thread)

-Chris
i have forgotten about the headlight washers...i dont even know if they work..
 

·
Registered
Joined
·
101 Posts
Glad I read this......

Took mine in for the wiper coming on when turning..I don't even have to use the turn signal, it just comes on two or three times every fourth or fifth sharp turn while the auto-wipers are on. The tech said something on the stem needed to be replaced. Is this a software or stem issue????? I asked them late last year if they could update my software(currently 3.54v) and were either ignorant of any updates or just too lazy to take the time to do it.
 

·
BLOODY ADMENSTRUATOR
Joined
·
12,606 Posts
myrtle300c said:
Took mine in for the wiper coming on when turning..I don't even have to use the turn signal, it just comes on two or three times every fourth or fifth sharp turn while the auto-wipers are on. The tech said something on the stem needed to be replaced. Is this a software or stem issue????? I asked them late last year if they could update my software(currently 3.54v) and were either ignorant of any updates or just too lazy to take the time to do it.
Software. Several threads on this. Upgrade to 3.61. Should fix the problem along with several other issues. It was issued July 24, 2004, and is strongly recommended for your car.

Hope this helps.
 
1 - 19 of 19 Posts
Top