Chrysler 300C & SRT8 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I am hoping someone can help me out... I've done a lot of looking on the forum and can't seem to find a complete answer to my specific setup.

So here's my question... I'm installing an AVIC-D3X into a 2007 300C and need help getting the right wiring harnesses. The car came with a single disk HU REF model the 6 Speaker Boston Acoustic setup without an AMP (I looked to the left of the steering column and didn't see an amp I think) also I have the steering wheel controls that I want to retain.

I think I have everything else to do the install, like the antenna adapter, double din kit and NAV bezel, but if there is anything I maybe missing please let me know.

This will be my 4th D3 install overall they are pretty easy to install and they are pretty good unit for the price. I installed one for my wife and she loves it in her Expedition and I'm very happy with it in my 04 Mustang Cobra.

Thanks in advance for the help.
 

·
Registered
Joined
·
266 Posts
I am hoping someone can help me out... I've done a lot of looking on the forum and can't seem to find a complete answer to my specific setup.

So here's my question... I'm installing an AVIC-D3X into a 2007 300C and need help getting the right wiring harnesses. The car came with a single disk HU REF model the 6 Speaker Boston Acoustic setup without an AMP (I looked to the left of the steering column and didn't see an amp I think) also I have the steering wheel controls that I want to retain.

I think I have everything else to do the install, like the antenna adapter, double din kit and NAV bezel, but if there is anything I maybe missing please let me know.

This will be my 4th D3 install overall they are pretty easy to install and they are pretty good unit for the price. I installed one for my wife and she loves it in her Expedition and I'm very happy with it in my 04 Mustang Cobra.

Thanks in advance for the help.
You have an amp if you have the 6 speaker BA system. You need the pac c2r chy wiring harness (and with this you can retain the use of the factory amp), and if you want to retain steering wheel controls you need the pac swi can and pac swi ps adapters as well.
 

·
Registered
Joined
·
1 Posts
i was thinking of upgrading my radio too

so... if I'm reading correctly i can keep my steering wheel controls? (i'm sure i'll lose my nav controls?) and this requires 3 pac adapters OK that s pretty straight up. but whats the deal with the factory amp do you have to keep it or if I dont want to keep it does the boston accoustics stuff have to be rewired???

i have a 05 c with nav rec unit and would really like a touch screen
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Is there anyother place that the Factory amp would be other than to the left of the steering column? I just looked and I don't have an amp there. I also pulled my window sticker and I don't have any options related to the stereo listed.

I've heard of chrysler not putting amps with the 6 speaker system. does anyone have a picture of what the amp looks like I may be missing something?

Thanks.
 

·
Registered
Joined
·
3,692 Posts
so you have a boston logo in the sail panel in each front door?

There was an option that had 6 speakers but they were not boston.

Do you have a sound group option on your sticker? If not, you don't
have an amp and not likely the boston setup. Check the sticker and
see if there is a sound group option such as I or II listed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
I have the Boston logo on both door sail panels and no Sound Group option on the window sticker. Under the standard equipment section it lists a single CD AM/FM radio and under that it says 6 Boston Acoustics Speakers.

This was a 2007 left over that had very little extra except the protection group II and power sunroof thats it.
 

·
Registered
Joined
·
1,283 Posts
so... if I'm reading correctly i can keep my steering wheel controls? (i'm sure i'll lose my nav controls?) and this requires 3 pac adapters OK that s pretty straight up. but whats the deal with the factory amp do you have to keep it or if I dont want to keep it does the boston accoustics stuff have to be rewired???

i have a 05 c with nav rec unit and would really like a touch screen
...that would depend on what unit you are swapping to. If you bought a unit with NAV you would not loose any control providing the PAC modules were set up properly (programmed at the point of installation). Im running the Alpine HubPro and its perfect. New amps added and full control from steering wheel.
 

·
Registered
Joined
·
3,692 Posts
The question still remains, though, if you don't have an amp, then your harness requirements may be different.

The SWI-CAN is needed to adapt your steering wheel controls. The SWI-PS is needed so that the SWI-CAN will talk to your AVIC.

Now, I suspect you should double-check with PAC. The debate is
whether you need the C2R-CHY or the C2R-CHYNA. The NA is the
adapter when you don't have an amp.

Question is also whether you need both the SWI-CAN and SWI-PS. I think
both are..
 

·
Registered
Joined
·
78 Posts
i have an 07 300c and all i had was the factory radio with 6 BA speakers. no mention of an amp was on the window sheet, however it is there. i took my dash apart yesterday and the amp is in there but its hiding behind a black bbox that says siemens. if you have the BA syytem you must have the factory amp. i heard the same thing about some of them not having it but i think that is just do to people not looking hard enough. it took me about an hour to finally find it. with that said, i went a little different route. i bought the metra chto-01 adapter that plugs into the d3 and the factory radio harness plugs right into it. you dont even need to connect anything to the amp. on the chto-01 there are 4 rca's....purple,green,white and grey. theses rca's connect right into the d3's rca's. the green and purple connect to the front speaker output rca's that come out of the d3. the white and grey rca's connect to the rear speaker outputs. check those first b/c i may have said those backwards. but that was it. i thought i was going to have to pluug something into the factory amp and that is why i was looking for it but you dont even touch the amp doing it this way.....ill put pics of later. hope this helps
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Everyone thanks for the help I'm going to order the part tonight assuming I have an amp. Hopefully everything arrive before next weekend and I can install on Saturday. I'll let you know how it turns out.
 

·
Registered
Joined
·
3,692 Posts
i have an 07 300c and all i had was the factory radio with 6 BA speakers. no mention of an amp was on the window sheet, however it is there. i took my dash apart yesterday and the amp is in there but its hiding behind a black bbox that says siemens. if you have the BA syytem you must have the factory amp. i heard the same thing about some of them not having it but i think that is just do to people not looking hard enough. it took me about an hour to finally find it. with that said, i went a little different route. i bought the metra chto-01 adapter that plugs into the d3 and the factory radio harness plugs right into it. you dont even need to connect anything to the amp. on the chto-01 there are 4 rca's....purple,green,white and grey. theses rca's connect right into the d3's rca's. the green and purple connect to the front speaker output rca's that come out of the d3. the white and grey rca's connect to the rear speaker outputs. check those first b/c i may have said those backwards. but that was it. i thought i was going to have to pluug something into the factory amp and that is why i was looking for it but you dont even touch the amp doing it this way.....ill put pics of later. hope this helps
the pac pretty much works the same way. You work behind the radio,
no need to go to the amp. And even though you didn't work at the amp,
you still impacted the connection to the amp when you connected the
chto to the stock harness. this is the same thing with the pac.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
I installed everthing yesterday and it went off without a hitch. The only issue I'm having is with the Sirius add on. I think its a ground wire issue hopefully I'll resolve it today. All three PAC modules worked perfectly and programming was too much of issue.

Thanks for all the help... I post pics later.
 

·
Registered
Joined
·
1,283 Posts
I installed everthing yesterday and it went off without a hitch. The only issue I'm having is with the Sirius add on. I think its a ground wire issue hopefully I'll resolve it today. All three PAC modules worked perfectly and programming was too much of issue.

Thanks for all the help... I post pics later.
...good to hear it all worked out for you. Enjoy.
 
1 - 15 of 15 Posts
Top